troubleshooting ignition please help - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-24-2009, 06:45 PM Thread Starter
Registered User
 
Join Date: Feb 2007
Location: Simpsonville ,SC
Posts: 53
troubleshooting ignition please help

I just recently bought a 67 F100. It has a 352 with auto trans. The wires, plugs and points were shot. So I replaced all of these plus the condenser, rotor, and cap. It fixed much of my trouble but now under constant throttle it seems to miss or sputter. If I accelerate it cleans up but if I let out of it and try to maintain a constant speed it misses. The distributor is a dual advance autolite. The engine itself has 66000 original miles but hasn't been driven in years. It smokes, but I figure being driven might help clear that up. Any help with the ignition miss would be appreciated!

1966 Galaxie 500 Fastback
HEAVYdebt66 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-24-2009, 07:26 PM
Banned
 
Join Date: Jul 2005
Location: central NY 13208
Posts: 6,355
Re: troubleshooting ignition please help

make sure # 7 & 8 wires don't run next to each other smokes , with the age of the engine valve guide seal might need replacing

Last edited by DanH; 06-24-2009 at 07:28 PM.
DanH is offline  
post #3 of 3 (permalink) Old 06-24-2009, 11:17 PM
Registered User
 
Join Date: Aug 2006
Location: Greater Puget Sound Area
Posts: 4,003
Re: troubleshooting ignition please help

It sounds like it might be a lean surge. You might have to increase the jet size by 2 sizes to get it to cruise smoothly.

66 Mustang Coupe. 365hp, 4spd Toploader, sub-frame connectors
Shelby drop, suspension tuned for slalom and hill climb
body mods and weight reduced to 2000lbs; name: Muskrat
PaulS1950 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting your ignition system dazecars Ignition Articles 19 10-08-2018 10:34 AM
Ignition Troubleshooting? Dees66 The Garage 5 02-28-2005 03:18 PM
MSD Troubleshooting mrguts All Ford Techboard 4 10-02-2004 09:07 PM
troubleshooting 460 cantedvlv All Ford Techboard 5 06-13-2003 11:26 AM
troubleshooting fe clods64fe All Ford Techboard 2 01-03-2003 07:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome