Ford Muscle Forums : Ford Muscle Cars Tech Forum

Ford Muscle Forums : Ford Muscle Cars Tech Forum (https://www.fordmuscleforums.com/forumindex.php)
-   All Ford Techboard (https://www.fordmuscleforums.com/all-ford-techboard/)
-   -   03 Windstar transmission problem (https://www.fordmuscleforums.com/all-ford-techboard/488573-03-windstar-transmission-problem.html)

Yaap 08-05-2009 01:16 PM

03 Windstar transmission problem
 
My good friend has a 2003 Windstar and the transmission went bad or so that's what the mechanic says. He was told it will be $2300 for a rebuilt one to be install.
Symptoms : It wont go in drive or revers "All the gear fill like neutral", It shows way to much fluid when check with the dip stick. He claims no fluid was added by him or the mechanic. No Check engine light or codes.
I think the torque converter went bad and push all the fluid into the tranny.
What do you think????????

Yaap 08-07-2009 12:28 PM

Re: 03 Windstar transmission problem
 
Nobody???????????

gbic1 08-07-2009 12:59 PM

Re: 03 Windstar transmission problem
 
I already answered this question. You must have double posted. Sounds like the pump went bad.

Yaap 08-14-2009 05:53 AM

Re: 03 Windstar transmission problem
 
How can I test the pump or the torque converter?

Bullitt331 08-14-2009 06:31 AM

Re: 03 Windstar transmission problem
 
There is a test port on the transmission case that lets you put a transmission pressure tester on and then you start the car and see if the pump has the proper pressure. The trans pressure gauge should read over 200 psi if I remember right. The specs can be found in Alldata or a Mitchel manual or shop service manual. Those manuals will also show where the test port is on the trans.

FEandGoingBroke 08-14-2009 09:27 AM

Re: 03 Windstar transmission problem
 
Listen to Bulllitt, he is making sense.

Lupins 08-14-2009 09:33 AM

Re: 03 Windstar transmission problem
 
Somthing crazy to check Iv seen it quite a few times. Not sure if it applies to your year. Water gets into the PCM and screws up the trans wont engauge etc. When It happens you would swear the trans is totally destroyed. Take apart the pcm and blow dry it with a blow gun and same with the connecter. Greese it up with electrical greese and seal it and thecover so it wont happen again. It only takes 15min to check out might be worth a look. Just remove the two piece cowl and its on the pass side.


All times are GMT -7. The time now is 01:11 AM.

Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome