03 Windstar transmission problem - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 08-05-2009, 01:16 PM Thread Starter
Registered User
 
Join Date: Jan 2004
Posts: 148
03 Windstar transmission problem

My good friend has a 2003 Windstar and the transmission went bad or so that's what the mechanic says. He was told it will be $2300 for a rebuilt one to be install.
Symptoms : It wont go in drive or revers "All the gear fill like neutral", It shows way to much fluid when check with the dip stick. He claims no fluid was added by him or the mechanic. No Check engine light or codes.
I think the torque converter went bad and push all the fluid into the tranny.
What do you think????????

All original 345,000 miles 94 Ford Ranger
Yaap is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-07-2009, 12:28 PM Thread Starter
Registered User
 
Join Date: Jan 2004
Posts: 148
Re: 03 Windstar transmission problem

Nobody???????????

All original 345,000 miles 94 Ford Ranger
Yaap is offline  
post #3 of 7 (permalink) Old 08-07-2009, 12:59 PM
Registered User
 
Join Date: Nov 2006
Location: Peotone IL
Posts: 2,211
Re: 03 Windstar transmission problem

I already answered this question. You must have double posted. Sounds like the pump went bad.

Looking for FE fenderwell headers.
https://www.fordmuscleforums.com/maki...ml#post1745153
gbic1 is offline  
 
post #4 of 7 (permalink) Old 08-14-2009, 05:53 AM Thread Starter
Registered User
 
Join Date: Jan 2004
Posts: 148
Re: 03 Windstar transmission problem

How can I test the pump or the torque converter?

All original 345,000 miles 94 Ford Ranger
Yaap is offline  
post #5 of 7 (permalink) Old 08-14-2009, 06:31 AM
Subscriber
 
Join Date: Feb 2009
Location: Pacific NW
Posts: 425
Re: 03 Windstar transmission problem

There is a test port on the transmission case that lets you put a transmission pressure tester on and then you start the car and see if the pump has the proper pressure. The trans pressure gauge should read over 200 psi if I remember right. The specs can be found in Alldata or a Mitchel manual or shop service manual. Those manuals will also show where the test port is on the trans.
Bullitt331 is offline  
post #6 of 7 (permalink) Old 08-14-2009, 09:27 AM
Premium Member
 
Join Date: Sep 2004
Location: Sunny Arid Desolate Port Orchard WA
Posts: 34,853
Re: 03 Windstar transmission problem

Listen to Bulllitt, he is making sense.
FEandGoingBroke is offline  
post #7 of 7 (permalink) Old 08-14-2009, 09:33 AM
Registered User
 
Join Date: Sep 2003
Posts: 847
Re: 03 Windstar transmission problem

Somthing crazy to check Iv seen it quite a few times. Not sure if it applies to your year. Water gets into the PCM and screws up the trans wont engauge etc. When It happens you would swear the trans is totally destroyed. Take apart the pcm and blow dry it with a blow gun and same with the connecter. Greese it up with electrical greese and seal it and thecover so it wont happen again. It only takes 15min to check out might be worth a look. Just remove the two piece cowl and its on the pass side.
Lupins is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission problem ? Deome All Ford Techboard 13 06-03-2009 09:51 AM
C4 Transmission Installation Problem otherguy All Ford Techboard 10 03-09-2009 11:39 AM
transmission problem Aaron7621 C4 Transmissions 6 01-11-2005 03:50 AM
Trouble shooting automatic transmission problem argodealer All Ford Techboard 1 08-10-2003 09:45 PM
Problem with T-10 transmission falcon64 All Ford Techboard 2 12-14-2002 05:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome