302 acceleration issue and alternator light! - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-28-2010, 08:23 PM Thread Starter
Registered User
 
Join Date: Apr 2010
Posts: 91
302 acceleration issue and alternator light!

so I got some free time to mess with my 68 mercury montego today and took it to get gas, first thing I noticed was behind the gas door in the crease between the gas filler tank and the quarter panel it is filled with water...I think that may be because the gas lid doesnt have a seal but I may be wrong. The main issue that I had was the car accelerating normally and slowly but when I tried to full throttle or burn out in the parking lot the car cut off and stalled, I started up the car and the same thing happened, then in park when I was revving the car everytime I revved the red alternator light on the dash came on, is that normal? I figure fuel or ignition problem not sure, i havent tuned it up since I bought it so I dont know if its because of that either.
mikestylezz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Light throttle issue. RobGT All Ford Techboard 0 03-23-2010 10:02 PM
Help ID dash light issue Dr B Smith Galaxie Pages 4 09-28-2009 05:05 PM
Brake light issue Goldineye All Ford Techboard 8 09-25-2009 03:33 PM
05-06 Alternator issue ! Blksunshine Mustang Pages (2005-2009) 1 11-15-2008 06:56 AM
Alternator Issue chump188 Galaxie Pages 14 12-18-2007 11:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome