66 galaxie acting weird - Page 2 - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 4Likes
Reply
 
LinkBack Thread Tools
post #16 of 17 (permalink) Old 04-04-2019, 03:07 PM
Registered User
 
Join Date: Mar 2014
Location: Indianapolis, IN
Posts: 229
Re: 66 galaxie acting weird

Two things I would test: First, with the engine off and air cleaner off, look down the carb and work the throttle. You should see two streams of gas from the accelerator pump squirting. If not there are fuel problems (fuel pump or filter, float setting, debris in the carb., etc.). Second, check your timing with a timing light. Maybe the distributor clamp is loose and the distributor got bumped, changing the timing enough that it's hard to start but runs okay afterward.


Pat

1964 Galaxie 500 2 dr Fastback, 390, 4 speed, Indianapolis Indiana
1964Fastback is offline  
Sponsored Links
Advertisement
 
post #17 of 17 (permalink) Old 04-04-2019, 05:00 PM
Registered User
 
Join Date: Jun 2018
Posts: 327
Re: 66 galaxie acting weird

also for the hard start, jumper from b+ to pos side of coil then try to start. starter relay could be going bad
1964Fastback likes this.
extech is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
*** Carter AFB acting weird, need guidance! *** nah2323 All Ford Techboard 5 09-20-2009 07:56 PM
C6 Tranny acting weird.... 72BlackOnBlack All Ford Techboard 2 01-02-2008 09:46 PM
weird weird shifting problem XolieX All Ford Techboard 8 05-30-2006 05:21 PM
is my fuel pressure reg acting weird? Hottarod All Ford Techboard 1 09-30-2004 03:04 AM
AOD acting like 2 gears at once in 3rd crash_out Late Model EFI Techboard 2 09-20-2002 02:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome