Timing confusion 351E - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-05-2019, 01:40 AM Thread Starter
Registered User
 
Join Date: Oct 2018
Posts: 1
Timing confusion 351E

i bought a 1969 galaxy. the motor has been rebuilt before me. the tag near the distributor says it has a 351 E motor, however, the timing pointer is on the driver side and the balancer has no marks on it. seems to be running advanced. the data plate also has a K-20 or K28 which i cant find in any publications.
hdridr67 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-05-2019, 03:20 AM
Premium Member
 
Join Date: Apr 2004
Location: Perth, Western Australia.
Posts: 5,363
Re: Timing confusion 351E

Being a 1969, it would most likely be a 351W, but anything could have changed over 50 years.
Perhaps a photo of the engine would be better to ID it.

2003 Falcon BA XR8 Ute.
1972 Falcon XA GT.
1970 Galaxie 500 Sportsroof.
1963 1/2 Galaxie 500 Fastback.
danv is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
hurst shifter confusion?? dark7068 All Ford Techboard 4 05-05-2004 03:41 AM
transmission confusion anotherproject Galaxie Pages 3 11-14-2003 01:34 PM
Help with confusion about cams!!! Hardtimes All Ford Techboard 3 01-22-2003 05:07 PM
confusion on frame motor mounts dave65FB All Ford Techboard 10 01-31-2002 02:56 PM
AM/PM confusion gttorinofan The Garage 1 01-28-2002 10:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome