Not downshifting - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 05-19-2007, 02:21 AM Thread Starter
Registered User
 
Join Date: Oct 2002
Posts: 764
Not downshifting

I removed my RMVB and reinstalled an automatic valve body. The auto valve body has been sitting for a few years.

At first the car wouldn't shift into third, but a new modulator fixed that problem.

Now, the car will NEVER downshift on its own. If it is in third, when I come to a stop, it stays in third. I can manually shift it down to first or second, but it should go there on its own.

I'm thinking that the governor isn't working properly. It didn't serve a purpose with the RMVB.

Am I looking in the right direction and can I access it without pulling the tranny?



385 ci Cleveland. 10.95 @ 127 mph. Street tires and mufflers.
ScreaminC is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-19-2007, 03:08 AM
Subscriber
 
Join Date: Jan 2001
Location: Australia
Posts: 4,295
Not downshifting

If the upshifts are good i would maybe suspect a shift valve hanging up a little and not returning fully. I had a rebuild i did a few years ago do this but it came good on its own.
gregaust is offline  
post #3 of 7 (permalink) Old 05-20-2007, 12:28 AM
Registered User
 
Join Date: Aug 2006
Location: Greater Puget Sound Area
Posts: 4,003
Not downshifting

Were the governor distribution tubes removed when the manual valvebody was installed? Did you reinstall them when you put the old valve back in?
Paul
PaulS1950 is offline  
 
post #4 of 7 (permalink) Old 05-21-2007, 01:42 PM Thread Starter
Registered User
 
Join Date: Oct 2002
Posts: 764
Not downshifting

I am 80% sure that the governor tubes were left in when the RMVB was installed. The guy that built the tranny and I talked about it then, and now, and well..... we're 80% sure.



385 ci Cleveland. 10.95 @ 127 mph. Street tires and mufflers.
ScreaminC is offline  
post #5 of 7 (permalink) Old 05-21-2007, 02:51 PM
Registered User
 
Join Date: Jan 2006
Location: Moose Jaw, Saskatchewan, Canada
Posts: 547
Not downshifting

The governor is hanging up.
Stuarta is offline  
post #6 of 7 (permalink) Old 05-22-2007, 11:56 AM
Registered User
 
Join Date: Aug 2006
Location: Greater Puget Sound Area
Posts: 4,003
Not downshifting

Pull the driveline and extension housing. from there you can check out the governor and the distribution tubes. You are describing governor problems - you just have to pin it down.
While you are at it replace the thimble screen under the governor too - that might prevent future problems.
Paul
PaulS1950 is offline  
post #7 of 7 (permalink) Old 05-23-2007, 01:39 AM Thread Starter
Registered User
 
Join Date: Oct 2002
Posts: 764
Not downshifting

Thanks Paul. I will pull apart my 'parts' tranny so that I know exactly what I'm looking at before tearing into the car. I did not know there was a screen. I will definitely check into it, but this tranny has been rebuilt many times in the last 200 miles, so it BETTER be new and clean!!!!
ScreaminC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome