Forward Clutch sealing issues - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 1Likes
  • 1 Post By KickDown
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 07-17-2018, 10:45 AM Thread Starter
Registered User
 
Join Date: Jun 2015
Location: Gifhorn, Germany
Posts: 5
Forward Clutch sealing issues

Has anyone experienced sealing problems during an air pressure test between the 2 sealing rings on the stator support that seal the oil channel to the forward clutch in the clutch hub? I have a C4 on the bench that gradually lost all forward gears. I rebuilt the transmission about 2 years ago & everything with the air pressure test checked out fine. Now on disassembly the forward clutch is toast!!. Reverse/High clutches look brand new. I put the pump in a holding fixture & stacked both clutch drums on it. I blew compressed air into the respective holes in the pump for both clutches after squirting a syringe full of ATF into each hole & as I expected the rev/high clutch engaged with a thud but the forward clutch piston only moved very little accompanied by a hiss of air from the 2 sealing rings on the stator support. These are steel sealing rings & are brand new. I cannot source any teflon rings here in Germany & am wary of using them in a street application. I have built countless C4s & never had a sealing problem with steel rings in the past. If anyone has had this problem before (Greg) I would love to hear from you.
Cheers. Gaz
KickDown is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-06-2018, 08:43 PM
Registered User
 
Join Date: Apr 2011
Location: Edmonton, Alberta Canada
Posts: 387
Garage
Re: Forward Clutch sealing issues

Check the bore in the drum.
Remove the rings from the stator support and fit them in the drum.
They must fit snug and compress in the bore.
The ends of the rings should almost butt.

There is a small chance the bore in the drum is egg shaped.
Not common, but it does happen.
Make sure the bore is perfectly round.
galaxiex is offline  
post #3 of 5 (permalink) Old 09-07-2018, 05:05 AM Thread Starter
Registered User
 
Join Date: Jun 2015
Location: Gifhorn, Germany
Posts: 5
Re: Forward Clutch sealing issues

Thanks for taking the time to reply! I miced the bore with a 3 point micrometer, it was max 0.003 out of round which I think the sealing rings should compensate. I have the trans reassembled & in the car & it is holding up fine. Just a matter of time I guess.
KickDown is offline  
 
post #4 of 5 (permalink) Old 09-07-2018, 11:25 PM
Subscriber
 
Join Date: Jan 2001
Location: Australia
Posts: 4,284
Re: Forward Clutch sealing issues

Somehow I missed this post, just saw it now . I've not had issues . There are two different width sealing rings , pre 78ish and after is wider . I'm guessing the widths were correct for the stator support?

I test fit every ring in its bore to check prior to assembly.

I did get a wrong ring in a kit a little while ago. Luckily my thorough prechecks I always do picked it up. It could of gone unnoticed

My rule is if using a valve body with modulated line pressure gets steel rings , constant pressure V/B gets teflons
gregaust is offline  
post #5 of 5 (permalink) Old 09-07-2018, 11:33 PM Thread Starter
Registered User
 
Join Date: Jun 2015
Location: Gifhorn, Germany
Posts: 5
Re: Forward Clutch sealing issues

Thanks Greg. Yes I was aware that there are different width sealing rings. I always compare what I take out to what is going in & never throw anything away until the transmission is back in the car & running. Thanks for your answer. The trans is working fine fine now. Just see if it holds up permanently.
gregaust likes this.
KickDown is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
forward clutch drum LongIslandStang C4 Transmissions 2 04-18-2004 09:20 PM
Forward clutch piston retaining ring papadaddy All Ford Techboard 1 04-12-2004 09:36 PM
C4 stator support/forward clutch sealing rings ???? gregaust All Ford Techboard 3 02-18-2004 08:20 AM
Anyone seen the new billet C4 forward clutch drums from art carr? gregaust All Ford Techboard 8 11-25-2003 06:17 AM
C4 Trashed Forward Clutch - Cause? Pics... 1965FALCON All Ford Techboard 8 08-27-2003 11:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome