302 to 351w swap with C4, now terrible noise - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 01-17-2019, 06:12 PM Thread Starter
Registered User
 
Join Date: Jan 2019
Posts: 1
302 to 351w swap with C4, now terrible noise

swapped out a 302 out of a 73 mustang for a 351windsor (1978). C4 transmission was left in place and worked well prior. Obtained new flexplate (pioneer fra-203). It was same diameter and teeth number as the previous flexplate on the 302.

Car seemed to run and sound fine upon starting. After driving at low speeds noticed some difficulties shifting into drive or reverse (the shifter moved freely but seemed to not drop into gear every time) as well as a faint scraping noise. The noise was consistent w scraping of torque convertor based on some youtube videos. Attempted heavier acceleration which yielded a terrible scraping/ fan belt slipping sound from the transmission.

I properly torqued and apples loctite to flexplate and convertor bolts and they were still tight at disassemble. The converter was seated properly on shaft at assembly.

I noted scrape marks on spacer plate and also that the flexplate was approximately 3/16 in thinner that the old flexplate.

I am not sure how to go forward and if it was the flexplate being thinner and which I should get. I have included photos. Any advice would be appreciated
Attached Thumbnails
Click image for larger version

Name:	IMG_0472.JPG
Views:	20
Size:	64.5 KB
ID:	156711  
samckay is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Introducing.......Granny Terrible spillmk1 Fairlane Pages 15 09-28-2011 03:15 AM
My 302 running terrible in the rain!?!? help... hotrodder68 All Ford Techboard 3 07-31-2008 11:56 AM
Terrible fuel economy in my 6cyl Falcon.... tuning questions.... EricRose999 All Ford Techboard 26 03-25-2007 07:28 PM
\'63 Merc stance...tall and terrible!!!!!!! FEandGoingBroke Galaxie Pages 13 06-29-2005 08:28 AM
did i make a terrible mistake??????? XolieX The Garage 43 01-26-2003 10:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome