help!!my 67 wont start - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 08-29-2008, 10:01 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 5
help!!my 67 wont start

hey guys i got a big problem
i have a automatic 67 fairlane that wont start when i turn the key it just indicates that its "hot"
the story is i drove home from a friends house, parked it, next day i went to start it and nothing happens,no noise, absolutely nothing
it used to have a column shifter but there's a aftermarket b&m floor shifter
i suspect it might be the neutral safety and if i could bypass it or something that might do it but iam a grease monkey not an electrician
any help would be very appreciated
egghat is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-30-2008, 11:05 AM
Registered User
 
Join Date: Aug 2008
Location: Butler, IN
Posts: 6
Re: help!!my 67 wont start

Take a look at the plug going into the back of the ignition switch. If it's burnt, it will give you this condition. If so, replace the ignition switch.
Email me at [email protected]
thdunk is offline  
post #3 of 7 (permalink) Old 08-30-2008, 11:33 PM
Registered User
 
Join Date: Sep 2003
Posts: 847
Re: help!!my 67 wont start

This has happened to mine lots of times easy fix. It was the micro swith on the B&M shifter. its located under the cover on the shifter. Mine had a wire that kept falling off I just crimped it and has been fine since. undo the 4 screws below the handle and you should be able too see it .
Lupins is offline  
 
post #4 of 7 (permalink) Old 09-04-2008, 07:17 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 5
Talking Re: help!!my 67 wont start

i tried these suggestions and i even replaced and moved the neutral safety to the floor shifter
its still "hot"
now that i think about it my friend hooked my stereo up to play without the key in the ignition but it ran fine after that....maybe that did it but i doubt it
battery has full juice......perhaps my car is just a piece of crap
thanks for the help though
egghat is offline  
post #5 of 7 (permalink) Old 09-04-2008, 09:47 PM
Registered User
 
Join Date: Sep 2003
Posts: 847
Re: help!!my 67 wont start

Try turning the key on and jumping the starter solinoid. Take bettery power to the trigger and see if it cranks. Dont run yourself over if its a standard. Good luck
Lupins is offline  
post #6 of 7 (permalink) Old 09-05-2008, 09:48 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Posts: 5
Re: help!!my 67 wont start

i tried that and the engine cranks over
must be the wiring disconnected somewhere between the ignition and solenoid
problem is, i cant find it
i think i might need a new ignition switch
additional help is very appreciated
egghat is offline  
post #7 of 7 (permalink) Old 09-06-2008, 09:10 AM
Registered User
 
Join Date: Sep 2003
Posts: 847
Re: help!!my 67 wont start

So if you used the small post to power and it cranks. We can assume there is no trigger getting to the solinoid. It wouldnt hurt to check with a test light. All thats left is the ignition switch wiring and Neutral saftey switch. On my car it had some wires heading down to the trans orginaly I think it had a conecter near the wiper motor. this is where I cut the wires and fed it inside the car for my B&M shifter to the neutral saftey micro switches. One micro was for rev and one for starting if I remember correct. When you said you checked them did you check the one for Neutral? also trace those wires back . (sorry I dont have a wiring diag handy to give better info) but I really think this is a problem with the neutral saftey system. If you can find a wiring diag trace those wires and jump them together see if it starts. check for that conection under the hood and where it goes back inside look for green wires or a bad connecter broken wires.
Lupins is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3 wont start? 351bolt All Ford Techboard 14 04-29-2008 04:52 PM
Car wont start when hot SeanF0101 All Ford Techboard 4 02-22-2008 09:25 PM
car wont start 65stang289 All Ford Techboard 4 12-30-2004 09:00 PM
car wont\' start Dave All Ford Techboard 3 11-10-2003 06:21 PM
Wont start Pat LaZansky All Ford Techboard 3 07-03-2002 10:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome