FMX issue after reseal - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-06-2016, 05:54 AM Thread Starter
Registered User
 
Join Date: May 2013
Posts: 151
FMX issue after reseal

Had my trans out to reseal. It was working fine before but leaking at each end. Now it is slipping instead of going into 3rd. It was fine around my house but after trying to get into third I noticed that it was also slow going into reverse.

To reseal between the case and tail housing I had to remove the governor and a couple of other parts.


Is it possible there is an issue with the governer that would impact reverse? Did i break something in the trans?


It was hard to pull everything back to get to the the gaskets. I did have to pry and hammer a little.

It looks like Inhave the fluid back up to where it should be after draining the pan.
kaw550 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
65 390 fmx swap to c6 rear mount issue djimbeau Galaxie Pages 8 11-30-2017 12:26 PM
charging issue/load issue 69 fairlane ventturei26 All Ford Techboard 27 11-05-2011 07:45 AM
c4 slipping after reseal please help sicksty4falcon C4 Transmissions 6 02-07-2010 02:45 PM
reseal power steering control valve? Blue Fastback All Ford Techboard 1 05-09-2006 06:33 AM
Reseal a P/S control valve? Blue Fastback Thunderbird Pages 0 05-08-2006 04:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome