1989 tbird 3.8 sc - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-27-2003, 06:14 PM Thread Starter
Registered User
 
Join Date: Mar 2003
Posts: 3
1989 tbird 3.8 sc

just got a 3.8 sc and it will not fire but turn over good just will not attem to hit
could this be a bad timeing chain or coil pack or computer
when you turn the key on you can hear a relay clicking in the computer any one with any ideal on what could be the problem
outlaw1953us is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-30-2003, 02:36 PM
Registered User
 
Join Date: Feb 2001
Posts: 48
1989 tbird 3.8 sc

If you post the question on sccoa.com they can help you out.The site is deticated to the sc t-birds.Good luck!
400falcon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome