9" ford housing - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-09-2018, 05:48 PM Thread Starter
Registered User
 
Join Date: Jul 2018
Location: Columbia,S.C.
Posts: 1
9" ford housing

Hello, I'm new to forum. I have a 9" Ford rear end on a 32 rod. I'm trying to figure out what oil seal fits inside housing. I pulled axle and it doesn't have a seal, so I have no idea what will fit. Seal needs to be 2.53 o.d.and axle diameter is 1.53. Anyone have any idea what seal I need ? Thank you in advance.
namvet6971 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-09-2018, 10:49 PM
Moderator
 
Join Date: Jun 2003
Location: Spanaway, WA
Posts: 21,510
Re: 9" ford housing

You should be able to go to your local auto parts store and get the seals. At least that's all i do. Make up a year etc of galaxie if you have to since most go by what the computer tells them. Or got to NAPA auto parts and they can look at their books. Hopefully they still do that!



1964 Galaxie 500XL convertible, 390 .030 over, Fedmogul rv pro-3000 cam

Always be yourself, because the people that matter don't mind, and the ones who mind, don't matter.

http://www.so-calgalaxies.com
http://www.galaxiesnw.com
ShotRod64 is offline  
post #3 of 3 (permalink) Old 11-22-2018, 07:44 AM
Registered User
 
Join Date: Oct 2018
Posts: 3
Some 9” housings do not use a seal in the axle tube. There should be an o ring on the outer diameter of the axle bearing. The bearing itself is sealed in this application. It is possible for the bearing to leak, which would require a new bearing.
S/S Ford is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
351c odd problem. Engine only starts when key goes back from "start" to "run" elvisjer All Ford Techboard 9 07-20-2016 06:05 AM
4 - 15" steel rims with markings "Ford" & "K H" 85Eldo Galaxie Pages 22 06-02-2016 06:07 AM
Combine "start" and "run" circuits krehmkej All Ford Techboard 0 08-06-2011 02:46 PM
"new" C6 won't "brake" in 2nd will4685 Galaxie Pages 6 11-13-2008 08:36 AM
No "Avitars", or "Billboard Sigs"...? frankenford The Garage 5 07-01-2008 08:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome