windstar transmission problems - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 08-06-2009, 01:06 PM Thread Starter
 
Join Date: Jan 2004
Posts: 148
windstar transmission problems

My good friend has a 2003 Windstar and the transmission went bad or so that's what the mechanic says. He was told it will be $2300 for a rebuilt one to be install.
Symptoms : It wont go in drive or revers "All the gear fill like neutral", It shows way to much fluid when check with the dip stick. He claims no fluid was added by him or the mechanic. No Check engine light or codes.
I think the torque converter went bad and push all the fluid into the tranny.
What do you think????????
Yaap is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-06-2009, 02:04 PM
Registered User
 
Join Date: Nov 2006
Location: Peotone IL
Posts: 2,211
Re: windstar transmission problems

Sounds like the pump went out and it cant fill the converter after drain back.

Looking for FE fenderwell headers.
https://www.fordmuscleforums.com/maki...ml#post1745153
gbic1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
03 Windstar transmission problem Yaap All Ford Techboard 6 08-14-2009 09:33 AM
Transmission problems HELP boogie Galaxie Pages 9 07-18-2009 06:44 PM
Transmission problems.....AGAIN!!!!! 472Mach1 All Ford Techboard 6 11-10-2003 11:59 AM
Transmission problems bonehe3d Falcon Pages 7 03-17-2003 09:41 PM
windstar problems - common? Fixes? dirtball All Ford Techboard 2 11-11-2002 12:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome