Problems with instrument panel on my 05' - Ford Muscle Forums : Ford Muscle Cars Tech Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-14-2009, 09:09 AM Thread Starter
Registered User
 
Join Date: Feb 2003
Posts: 185
Problems with instrument panel on my 05'

I am having some problems with the instrument panel on a 2005 Mustang. The Tach sometimes will not work at all and the speedo sometimes doesn't go down to zero, but it will stop on the 10. Both come and go. Any suggestions on what this could be? Thanks for any help
68stanger is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-20-2009, 08:40 AM
Banned
 
Join Date: Jun 2004
Location: Northern Utah
Posts: 864
Re: Problems with instrument panel on my 05'

Do you have the standard panel or the MyColor panel?
Both signals come from the PCM.
Ya may want to check for moisture or corrosion in the PCM connector.

Rich Sr.
ixtlan is offline  
post #3 of 3 (permalink) Old 09-30-2009, 04:39 PM
Registered User
 
ford4v429's Avatar
 
Join Date: Feb 2005
Location: NE Ohio
Posts: 3,336
Garage
Re: Problems with instrument panel on my 05'

Quote:
Originally Posted by 68stanger View Post
I am having some problems with the instrument panel on a 2005 Mustang. The Tach sometimes will not work at all and the speedo sometimes doesn't go down to zero, but it will stop on the 10. Both come and go. Any suggestions on what this could be? Thanks for any help
with the kinda common cowl leaks on 05/early 06 cars, I'd check for wet carpet on the passenger footwell first- if its damp, pull the kickpanel and dry out the 'smart junction box' behind the panel- most cases I heard of were odd taillamp situations(one bulb always on, etc) but as prettty much all the wiring goes thru there, I'd check for water first. look over at themustangsource.com in the warranty/service issues thread- theres a bunch about wet SJBs from poorly sealed cowls.

Tim

CONFIDENCE: that feeling you get just before you realize the mess you got yourself into...
Saving a 65 Galaxie
1969 Mustang project pics
ford4v429 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
1967 instrument panel donwhis Galaxie Pages 9 06-03-2009 12:49 PM
Instrument Panel Failure 65wagonmaster All Ford Techboard 2 11-10-2007 01:38 PM
Homemade instrument panel lees6t Falcon Pages 7 07-24-2007 07:22 AM
LED lamps for instrument panel smellslikeWD40 All Ford Techboard 5 11-19-2006 02:24 PM
68\' Mustang Instrument panel???? 68stanger All Ford Techboard 15 04-02-2003 06:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome