Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: 302 to 351w swap with C4, now terrible noise Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-17-2019 06:12 PM
samckay
302 to 351w swap with C4, now terrible noise

swapped out a 302 out of a 73 mustang for a 351windsor (1978). C4 transmission was left in place and worked well prior. Obtained new flexplate (pioneer fra-203). It was same diameter and teeth number as the previous flexplate on the 302.

Car seemed to run and sound fine upon starting. After driving at low speeds noticed some difficulties shifting into drive or reverse (the shifter moved freely but seemed to not drop into gear every time) as well as a faint scraping noise. The noise was consistent w scraping of torque convertor based on some youtube videos. Attempted heavier acceleration which yielded a terrible scraping/ fan belt slipping sound from the transmission.

I properly torqued and apples loctite to flexplate and convertor bolts and they were still tight at disassemble. The converter was seated properly on shaft at assembly.

I noted scrape marks on spacer plate and also that the flexplate was approximately 3/16 in thinner that the old flexplate.

I am not sure how to go forward and if it was the flexplate being thinner and which I should get. I have included photos. Any advice would be appreciated

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome