Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: Parking Brake Cables With an Explorer 8.8 Swap Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-24-2019 10:08 PM
bama64
Parking Brake Cables With an Explorer 8.8 Swap

I have a 64 2 door hard top I'm currently working on. I've got a T5 and an Explorer 8.8, 3.73 rear end under it. I'm trying to figure out the parking brake cables. I have the original Falcon cables that came with the car. I know you have to use adapter clips to connect them to the Explorer disc brakes, but I always thought you could use them. Well after cleaning mine up and painting the cable housings, I tried to put them back on the car but they don't look like they will work. They're are too long between the factory mounting tabs on the floor pans, and the mounting tabs on the Explorer.

What are my options for parking brake cables? If some of you have used the original cables, how did you make them work?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome