Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: Project Spirit of the Prince Magnum Channel Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-25-2016 09:10 PM
Princemagnum
Project Spirit of the Prince Magnum Channel

Project Spirit is a 1975 Maverick four door with an inline 250. She keeps killing her battery while running. Once you park her, you can't turn her back on because the battery is completely dead. We did a load test on the brand new alternator and it checks out fine as does the battery. we replaced the positive and the negative battery cables plus ground the wire to the new voltage regulator, and we checked the belt tension which was fine. We checked for any visible shorts and we can't find anything. There are no loose connections that we can see.. at this point, I'm utterly stumped. I can't find for any reason under the sun why she keeps draining her battery. Could it be a fuse or the solenoid acting up? Or is it something I'm over looking, maybe the starter? Any help is appreciated, thank you in advance.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome