Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: Tranny killing 1/4 mi time ?/Broader performance tranny Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-18-2004 03:22 PM
10secgoal
Tranny killing 1/4 mi time ?/Broader performance tranny

Yeah the tranny guy always gets blamed. Good thing it was only me. Well she was running just a tad lean. I ended up going up 4 in the front and 5 in the back for jets. The 60 ft hovered around 1.71 all night and was begining to spin of the line with the little extra ponies. I ended up with a best pass of 7.77 @ 86.68 with 1.74 60 ft of the bottle.
I don't actully remember if it was a street fighter or super or not. It is rated for 3000-3500, that I remember. I had to send the 2500 back to summit. I gave him all my specs and he sold me one that was way too tight.
I took it to the 1/4 to see what it would do and I could get the car to hook til I finally made it to the right lane. But that was a bottle run and the smcuck at the end threw away my slip so who knows. The car went from a 12.58 @105.25 to a 12.46 @ 107.23. But the 1/8 mii times were still at 7.9. So I can't wait to figure out what was different so I can run 7.7's on a 1/4 mi run.
04-17-2004 10:53 AM
jay427sohc
Tranny killing 1/4 mi time ?/Broader performance tranny

Everybody always blames the tranny guy. Youd think the engine would be considered 1st b4 the trans in a case like this. Theres only 1000 more variables in the engine tunning.

Jay www.broaderperformance.com
04-16-2004 09:43 PM
89 coupe
Tranny killing 1/4 mi time ?/Broader performance tranny

If your clutches were not right or "going away" you would be losing MPH each pass and you would be able to feel the slippage plus once it starts slipping the clutches will totally go away in seconds.
04-15-2004 09:41 AM
ckelly
Tranny killing 1/4 mi time ?/Broader performance tranny

I say tight beacause I run a Super Street Fighter and get 1.76~1.79 60's and it stalls about 3200~3400 at best. I could use about 400 more stall RPM. And a Street Fighter is tighter than mine.



04-14-2004 05:56 AM
10secgoal
Tranny killing 1/4 mi time ?/Broader performance tranny

That's what I don't understand. I figured if it was overfilled it would just comeout the top of the vent tube. Now I have run a 7.91 off the bottle. It's on the bottle that has me confused.You think it's too tight, really ? Hmmm. It comes out the hole pretty quick. It doesn't lift the wheels or anything though. I called around yesterday for prices on dynos. I don't even know where my timing should be yet. Hell or where to shift at this point. I'll keep the stall in mind though.
04-13-2004 02:34 PM
ckelly
Tranny killing 1/4 mi time ?/Broader performance tranny

I think your converter is way too tight. I ran a 7.85 back in Feb. at 86mph and there's no NOS tanks anywhere near my rig. I run a C4 with stock parts except for Alto clutch disks (the kit came from J.C. Whitney of all places) and don't have any problems (5 years, 370 runs and counting). Verify that your dip stick is correct for the trans so that you're not overfilling it. And be sure that it's vented properly. A deep pan may be in order to help the fluid stay settled but I don't see how fluid can be splashed out of the trans fill tube. It's usually pressure or a venting problem.




04-13-2004 02:13 PM
10secgoal
Tranny killing 1/4 mi time ?/Broader performance tranny

Well As for right now I have no traction problems right as of this moment.I consistantly pull 1.73-1.77 at the 60 ft. The "after it hooks " was to mean that I don't spray it right out of the hole because of the 8 in. I wait till it is not going to spin from the hit. The car is very consistant. It is consistantly slow though. I nailed a 12.71 dial twice and a 12.72 twice after that.
For fogger 408, I don't leak that much out of the dipstick or I wouldn't even run it. The little that comes out ends up on my windshield, which is more of a pain than anything. I have a dedicated fuel system for the nitrous which has a 3/8 aluminum fuel line with a holley blue and a guage that I can see when I spray. It runs at 5.75 with 950-975 psi.
Mario428. Like I said if you read the thread I wasn't blaming him. I put it there because I noticed a thread in here and it seemed like people use them alot. I wanted to get their attention. I would have put "BP tranny sux" or something to that extent if that were the case. But I am perfectly happy with his parts,machine work and prices.
04-13-2004 12:14 AM
fogged408w
Tranny killing 1/4 mi time ?/Broader performance tranny

Quote:
On 2004-04-11 17:02, 10secgoal wrote:
Should I put on a locking dipstick?
Please do, your ruining the track for everyone else.

As far as your cars behavior on nitrous, sounds like you do need to tune it better. Have you actually looked at the fuel pressure guage while spraying at full throttle? What kind of fuel pump? Are you using a return stlye regulator? Do you have a traction problem?

I doubt your slipping clutches with that little hp.
04-12-2004 05:29 AM
Mario428
Tranny killing 1/4 mi time ?/Broader performance tranny

Quote:
On 2004-04-11 19:00, 10secgoal wrote:
We'll just ingore this post as I don't think you read it in full. Where did I say I blame BP?
In your title "Tranny killing 1/4 mi time ?/Broader performance tranny "
How else would anyone read that?
04-11-2004 10:43 PM
clevelandstyle
Tranny killing 1/4 mi time ?/Broader performance tranny

I DID read your post and I agree that you have tuning and traction problems that you can't blame on the trans.

Quote: I run a 100hp shot at 4k in first after it hooks and run it the full quarter.

You are going to have to get it hooking the same every time before you can pin point an ET problem.
I don't see any evidence from your post that you have any trans problems.
04-11-2004 07:00 PM
10secgoal
Tranny killing 1/4 mi time ?/Broader performance tranny

We'll just ingore this post as I don't think you read it in full. Where did I say I blame BP? They don't make the parts, he simply supplies them. If I were to point blame at him, I would simply call him. Why would I blame him in the same paragraph that I said I liked his work ? Only reason I mentioned BP was for advertising on his behalf for the great work he did on my drums. The only I posted was to know if it possible to ver power the clutches like that. If so, does this look that kind of a case.
As for you, I find it interesting you are so quick to make others dumb, your own post did that for you for not reading and understanding the post in it's entirety.
04-11-2004 05:43 PM
Mario428
Tranny killing 1/4 mi time ?/Broader performance tranny

Well I would think if your tranny was working that badly it would have completly fried itself by now.
I find it interesting that you seem quite willing to blame all your problems on 2 clutch packs you bought from Broader Perf when you obviously have serious tuning issues.
04-11-2004 05:02 PM
10secgoal
Tranny killing 1/4 mi time ?/Broader performance tranny

This is my first post here. I was told to come here because I need a few tranny questions answered that no one seems to know. I bought my internals from broader performance. I have raybestos blues in the direct,tans in the forward, and kolene steels. The direct was drilled and machined, and the forward was welded (in the hub?) for strength. The parts looked awesome. I'm just am not so sure the tans are holding.Oh, and Jay added a clutch and steel to each drum. It is a 302 in an old mustang. I run the bottle to go with it. Now it ran a 7.93 @ 86.5 mph and 12.58 @ 105.5. The car should be much faster. Then I was really dissapointed when I ran the bottle. 7.855 @ 91 and 12.14 @113. I can pull consistent 1.7 60ft on motor. I run a 100hp shot at 4k in first after it hooks and run it the full quarter.A 7.93 to a 7.855 on a 100 shot ?? I see guys run low 8's in the 1/8 and the use a 100 shot and goy to a mid 7. I thought I may push thru the converter, but I don't cross any different at the end of the track. Is my stall just slipping too much maybe ? I thought about a dyno to figure it out. But that can get expensive. Also on nitrous runs, the tranny likes to puke on the headers from the dipstick fill. WTF ? Should I put on a locking dipstick? I'm going to pull the pan and check for clutch in the bottom. But the more ideas the better. I really don't want to go to a 5 speed because I nailed my dial -in three times on Friday night. But I am certainly not going to throw away money chasing a problem around. I'd rather be racing. I just need to find out, something is definetly wrong.
If it helps.
TCI Streetfighter Stall
Broader perfomance tranny built by me
AFR 185's
X-303 cam
RPM AIR gap intake with 750 dp
3.80's in a 8 in rear end

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome