Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: 2004 6.0 questions Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-25-2017 11:54 AM
fugitive
2004 6.0 questions

So I'm going through my truck that sat for 3 years and prior to that had bad maintenance issues. ((purchased from my brother). I replaced the FICM and that helped alot but there are still some problems. 1st can some tell me if the alternator has to generate 14 or higher volts at a minimum for the engine to run right? Mine is currently about 13.8 max. 2nd the motor runs pretty good except when it levels out to 1500 rpms, at hat exact point it starts losing power almost stuttering. i have to feather the throttle to boost the rpms for it to start running smooth again. anyone have an idea what might cause this or have experienced the same problem? any advice on this or other tips would be greatly apperciated. thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome