Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: Brake lights and turn signals won’t work! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-20-2018 11:35 AM
BlueBird
Re: Brake lights and turn signals won’t work!

Did you happen to use a volt meter to check anything?
07-17-2018 05:10 PM
BrewBoy
Re: Brake lights and turn signals won’t work!

It appears likely that something was done wrong- it worked before, and now it doesn't. I can tell you that I had issues with brake lights & turn signals when I bought my '65, but replacing the mechanical switch down on the brake pedal corrected them all.
07-17-2018 04:50 PM
Ericklozano1
Brake lights and turn signals won’t work!

I have a 64 ranchero and I just recently replaced my column shifter sleeve because mine broke. When I hooked everything back up the brake lights and turn signals won’t work anymore. It’s all put back correctly I even check the diagram. Everything worked before btw. I’ve also checked the fuses behind the light switch and it’s fine. Anything helps!!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome