Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: No brake light before or after turn signal replacement Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-18-2019 03:01 PM
bam64
Re: No brake light before or after turn signal replacement

SOLVED!!!

It wasn't directly from this answer, but this answer got me in the right direction. For the first time since the fall of 2017 (no time to troubleshoot this last year) I'll be able to drive my car again!


Quote:
Originally Posted by 1964Fastback View Post
I'm looking at a wiring diagram for my 64 Galaxie. Hopefully your Comet is similar. It looks like the brake and turn signal filiments are the same ones, so if the turn signals are working then I agree that eliminates problems at the back end of the car.


I would start by unplugging both wires to the brake switch on the master cylinder. A cheap test light with a wire clip and a pointed probe would be the ideal tool here but volt meter can be used as well. Clip the lead to the engine, maybe a carb bolt. Touch the probe to the + terminal of the battery. It should light of course. Now use the probe to test each of the two wires that went to the brake switch. One of them should turn on the test light (the green w/red stripe in my case). If the light won't go on, figure out why. Maybe a bad fuse, or loose fuse clips.


If the light does go on, then try connecting the two brake switch wires together using a test lead or small bolt or something. This bypasses the brake switch. If the brake lights are now on, it is likely a bad switch. If not, leave the two wires jumpered together and move inside the car. Use the test light to see if the green wire (in my case) going into the turn signal switch has power to it (from the brake light switch).


Pat
I checked with the above method and my test light turned on, and then I was able to successfully bypass the brake switch to see the lights light up. (Aside: I had previously tried to bypass the brake switch to no avail leading me to believe that maybe I actually had two problems.)

This had me scratching my head because my multimeter said that the switch had continuity. Of course the switch is in a horrible place for removal, so I hadn't yet pulled it off. That's when it hit me. The wiring was fine, the switch was fine - I bet the switch isn't getting activated. Last year, my brake fluid had gotten very very low due to a leak. I had refilled it and the brakes were fine, but I thought well, maybe there is some air in the line. BINGO! I removed it, had my son push the brake to get some fluid to push through, then I reinstalled the switch while he had the pedal down. Viola. Pressure & brake lights. This doesn't explain to me why the brake pedal had any influence at all on any previous outcomes, but hey, I can live with the mystery if I can drive my car

Thanks to everyone who chimed in.

For future generations searching for this answer, I hope this was helpful for you. Did I need to replace my turn signal switch? Maybe, maybe not, but it kinda needed it anyway, so I'm not disappointed I did that.

Next up, fixing that slow brake fluid leak that was the root of the problem, but that's for a different weekend. Tonight, we drive.
05-18-2019 11:40 AM
1964Fastback
Re: No brake light before or after turn signal replacement

I'm looking at a wiring diagram for my 64 Galaxie. Hopefully your Comet is similar. It looks like the brake and turn signal filiments are the same ones, so if the turn signals are working then I agree that eliminates problems at the back end of the car.


I would start by unplugging both wires to the brake switch on the master cylinder. A cheap test light with a wire clip and a pointed probe would be the ideal tool here but volt meter can be used as well. Clip the lead to the engine, maybe a carb bolt. Touch the probe to the + terminal of the battery. It should light of course. Now use the probe to test each of the two wires that went to the brake switch. One of them should turn on the test light (the green w/red stripe in my case). If the light won't go on, figure out why. Maybe a bad fuse, or loose fuse clips.


If the light does go on, then try connecting the two brake switch wires together using a test lead or small bolt or something. This bypasses the brake switch. If the brake lights are now on, it is likely a bad switch. If not, leave the two wires jumpered together and move inside the car. Use the test light to see if the green wire (in my case) going into the turn signal switch has power to it (from the brake light switch).


Pat
05-18-2019 09:00 AM
bam64
Re: No brake light before or after turn signal replacement

Quote:
Originally Posted by 1964Fastback View Post
Agreed. When dealing with lighting issues like this I generally start outside the car, with the sockets, wiring and grounds. After all, these areas are more exposed to the elements and experience corosion, etc. before the more protected inside locations.


Pat

Finally getting back to this after a couple of weeks without any time for it, alas.

So I re-checked the wiring harness and did find one small issue, but it was not the ultimate fix.

My issue with the brake pedal causing the left flasher to go solid and the front signal not working were solved by swapping a couple of wires. So at this point I have good flashers everywhere, with or without the brakes. No brake lights under any circumstance. I'm basically back to where I started before the turn signal replacement. Considering earlier symptoms, I think it safe to conclude that the brake switch is fine (I also tested with my limited multimeter knowledge and it seems fine with that as well).

For those indicating a grounding issue... I could use some help in how to diagnose that. My gut says that you're right, but it feels so nebulous to me. Since there aren't any grounding wires, I assume the socket is just grounding directly to the chassis? How are they grounded? How do I test? I also don't understand why the turn signals would all work as expected in this case. Why would the grounding on the same bulbs and sockets be a problem for brakes and not for the turn signals?

This is so very frustrating. I appreciate all your help!
05-11-2019 04:42 AM
1964Fastback
Re: No brake light before or after turn signal replacement

Quote:
Originally Posted by AdrianS View Post
Make sure you have good grounds to the bulb sockets. Bad chassis grounds cause a lot of problems like this.

Agreed. When dealing with lighting issues like this I generally start outside the car, with the sockets, wiring and grounds. After all, these areas are more exposed to the elements and experience corosion, etc. before the more protected inside locations.


Pat
05-10-2019 02:47 PM
AdrianS
Re: No brake light before or after turn signal replacement

Make sure you have good grounds to the bulb sockets. Bad chassis grounds cause a lot of problems like this.
05-10-2019 12:18 PM
extech
Re: No brake light before or after turn signal replacement

turn signal switch determines which bulb flashes and which bulb stays on for bake light
05-10-2019 11:52 AM
bam64
Re: No brake light before or after turn signal replacement

Quote:
Originally Posted by Nite-owl View Post
Hi there,

Like yours, only right side flashed. I don't know why the flasher was faulty. I think it was on this forum that sombody advised me to replace it.

Mel
Mine flashes correctly when the brake is not depressed. It is only not flashing on the left when the brake is depressed. My flasher is pretty new, so rather than being faulty, I guess it could potentially be incorrect?

Quote:
Originally Posted by martyk98 View Post
I had a similar issue with my 67 GTX. The replacement turn signal switch wiring was not color coded correctly and placed in the proper sequence in the plug. We had to go through each wire and change two.
Do you happen to recall if you were experiencing other issues/symptoms as well with that?
05-09-2019 04:39 PM
martyk98
Re: No brake light before or after turn signal replacement

I had a similar issue with my 67 GTX. The replacement turn signal switch wiring was not color coded correctly and placed in the proper sequence in the plug. We had to go through each wire and change two.
05-08-2019 02:14 PM
Nite-owl
Re: No brake light before or after turn signal replacement

Hi there,

Like yours, only right side flashed. I don't know why the flasher was faulty. I think it was on this forum that sombody advised me to replace it.

Mel
05-08-2019 12:00 AM
carolinaclassi
Buy F 100 Classic Ford Truck Parts Online

Are you looking for the best quality F 100 Classic ford truck parts online? Carolina Classics is the manufacturer of best F-100 Classic Ford Truck Parts | Buy Ford F100 truck parts online at Carolina Classics. Donít go any further because Carolina Classics is a 35 years old manufacturers of the best F-100 Ford Truck Parts. Don't hesitate to call us on: 919-682-4211 if you need assistance on our new website.
05-07-2019 04:52 PM
bam64
Re: No brake light before or after turn signal replacement

@Nite-owl - cool. I can certainly give that a try. Was your flasher working otherwise? What is the reason a fix like that would work?
05-07-2019 02:40 PM
Nite-owl
Re: No brake light before or after turn signal replacement

Hi there,

Had the same probs with my '63 500XL. Replaced the flasher. Fixed!

Mel
05-06-2019 06:30 PM
bam64
Re: No brake light before or after turn signal replacement

Subject should be brake "lights" - it's both.
05-06-2019 06:26 PM
bam64
No brake light before or after turn signal replacement

I've read a handful of other brake light posts that have certainly pointed me in the right direction, but I'm not making any progress. I'm hoping for some more ideas.

Some background
64 Comet Caliente 260 V8, installed new turn signal switch in an effort to fix my brake light issue.
Car has had wiring replacement from prior owner.
Fuse Box appears to beÖ Packard Electric

Front

Headlights - both good
High Beams - both good
Front Left Signal - No (bulb looks good, but canít swap due to stripped screws at the moment)
Front Right Signal - Yes

Interior
Dome - good
Highbeam indicator - good
Left turn indicator - no
Right turn indicator - good

Rear
Taillights - both good
Backup lights - both good
Left Turn Signal - good without brake applied
Right Turn Signal - good with/without brake applied

Brake Lights - NO

Left Turn Signal stops flashing and goes solid when brake applied.

Since the brake action causes the left signal to go solid, I believe it's safe to say the brake switch is fine. If I disconnected the wires from the brake switch, the left signal does not go solid. If the switch is plugged and the fuse is out, same behavior. (this would seem obvious, but just stating it).

The fuse was good, something in my previous testing blew that fuse and I replaced it again.

It feels like maybe dissembling the new switch could be in order? Unfortunately, the switch I bought can't be disassembled like some others I've seen in videos online and I don't know that I'd have enough knowledge to diagnose it anyway without help.

Any ideas for anything else I can check?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome