Ford Muscle Forums : Ford Muscle Cars Tech Forum - Reply to Topic
Thread: AC issues in ford windstar Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Ford Muscle Forums : Ford Muscle Cars Tech Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-27-2017 11:29 PM
KenGene
AC issues in ford windstar

I had the clutch and AC compressor replaced about 6 months before. They fully vacuumed it out and the whole that fun tap. It was then fully charged. Sometimes the front runs cold, but not almost what it must while the back just runs hot. I had checked the PSI and the back low and front is way high. It will even haphazardly cycle throughout the entire vents. In case I am sitting in the car long enough it will get very hot and just start pushing throughout the air away. There can be a possibility of clog or maybe the intermingle door. I wish here I can get useful answers. HELP PLEASE!!!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome