Ford Muscle Cars Tech Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
53 Posts
Discussion Starter #1
O.K....this problem has haunted me since 1995!!! My brake lights & turn signals would only work when I pushed forward and held the turn signal wand forward. If I let go of it, neither would work. I replaced the turn signal switch and everything worked for a few months. Then the plastic piece that held the turn signal on a right-hand turn broke right away. (cheap reproduction???) Then...right after that, the rear brake lights and turn signals stopped working...of course unless I grab the turn signal wand and push it forward towards the engine compartment which puts me back to square one and back to 1995. The parking lights are always operable but the turn signals and brake lights are in-op unless I push forward on the turn signal wand. Something is happening to where the the steering column needs more load somehow or I'm missing a spring or something. =\

-E
 

·
Premium Member
Joined
·
5,572 Posts
Seems like you need to replace the turn signal switch?
 

·
Premium Member
Joined
·
53 Posts
Discussion Starter #3
Seems like you need to replace the turn signal switch?
I replaced it not too long ago and it worked for less than 6 months!! I have a feeling something that creates tension is either missing or misplaced. =\
 

·
Registered
Joined
·
103 Posts
Ya, those things can be a pain to get right. The only thing that keep the two contact together is a little circle clip. I have found on the cheeper reproductions that I usually have to bend the contact wire out slightly so they make a better contact before you put it back together.
 
1 - 4 of 4 Posts
Top