Ford Muscle Cars Tech Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
Does anyone know if a Weiand Xcelerator 2V intake is a direct bolt on.
I read on some forums that the Intake Ports are larger than the head so that the Head Ports would need to be ported.
Thanks,
 

·
Registered
Joined
·
4,589 Posts
Its a direct bolt on. We have one on ours, I think they are mistaken the 2V intake for the 4V.

The 4V ports are larger then the 2V. And if you use the 4V intake on the 2V you could open the ports a pinch on the head to make it "right".

Just bolt it on and go, So many "professionals" out there at times. It tends to get people all distorted.
 

·
Registered
Joined
·
9,251 Posts
The 2V ports might be slightly larger than the head ports - it depends. The Weiand ports should be about the same size as the Felpro 2V gasket. Bolt it on and run it.

_________________

1967 Falcon 4 door w/351C - Owner built, owner abused.
70 Mustang 302 / 06 Ranger, 04 SuperCrew parts hauler
http://raceabilene.com/kelly/hotrod

<font size=-1>[ This Message was edited by: ckelly on 12/10/06 11:11am ]</font>
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #4 ·
Thanks for the info:
I hope this will help my engine breathe better.
My 2V headed motor currently has a Edel. Performer and it will only REV. to about 5200 then stops. No valve float.
The Cam Manufacturer claims that it should make power to 5800.
The Cam specs. are Dur. 214/224 at (.050) Lift is .510/.530 and L/S is 112.
I have 3:70 rear gears,2500 Converter, Headers, adjustable valve train. Roller Rockers.
Do you think this is a wise move?
Thanks.

<font size=-1>[ This Message was edited by: Rancho Lenny on 12/11/06 1:25am ]</font>
 

·
Registered
Joined
·
777 Posts
Several years ago, I had a really mild cleveland; unported 2v heads, hydro cam that was 224/224, .540/.540, 108 lsa, standard bore, factory cast flat tops, stock single point distributor, cheap headers, shifted at 5400 rpm, etc, and I originally had an unmolested performer on it. It ran ok, but was nothing to brag about. I bought a used/but never actually bolted to a motor, xcelorator from a buddy, and stuck it on the motor. It picked up almost half a second in the qrtr from the swap. I never changed anything except for the intake. I ran the same carb, same timing, same old plugs, same shift point, etc. The gain was all from the intake swap. It 60' better, et'ed better, and had better mph.

And when street driving, I couldnt tell any loss of low end from the single plane intake.
 

·
Premium Member
Joined
·
1,825 Posts
I had the same problem with my 2v 351c, I had an Edelbrock 600 with a performer intake on it, My buddy said that if I went to a 650 holley and a Xcellerator intake and did not LOVE it he would pay for everything...... I did it and I swear im up 40 horsepower !!! I also have the same cam as you-
 
1 - 6 of 6 Posts
Top