Ford Muscle Cars Tech Forum banner

1 - 18 of 18 Posts

·
Premium Member
Joined
·
1,153 Posts
Discussion Starter · #1 ·
I'll be posting pics in this thread of install...Gremlins and all!
Coming down to the wire to be ready July 20th for the FCA Nationals. WILL BE BUSY FOR SURE!

1.7 Comp Stainless Roller Rockers
http://loco4fomoco.com/onehead15.JPG

_________________
<font color="blue">L8R,
Rick in Indy</font>
408 Clevor
Remember...Success is a Journey, Not a Destination



<font size=-1>[ This Message was edited by: FATNFAST on 7/7/06 11:34pm ]</font>
 

·
Premium Member
Joined
·
1,153 Posts
Discussion Starter · #4 ·
Well my brother came over, and we just busted butt, and got the motor and tranny in yesterday. no time to stop and take pics. Everything went pretty good, Except having to stop and go get a pilot bearing. I did screw up, I had flywheel, disc, and plate on before I realized I forgot to put on the engine plate to my scattershield ! Other than that, all went rather well.
 

·
Registered
Joined
·
813 Posts
SWEET!!! That is a work of art!!
And I also admire that Falcon Ranchero of yours too.
Its nice to see someone build something other than a Mustang.
 

·
Registered
Joined
·
9,251 Posts
Radical - you're not sneaking up on anyone with that. What intake is on the motor?
 

·
Premium Member
Joined
·
1,153 Posts
Discussion Starter · #10 ·
old Offenhauser Boss. I believe my throw out bearing is slipping off one of the pressure plate levers. The clutch is not pushing in without extreme levels of force. getting ready to pull tranny back out to see if throw out bearing is too small. Hope to solve that problem today.
 

·
Registered
Joined
·
9,251 Posts
Thought it was a 302 sized something. Good luck with the tranny problem.
 

·
Premium Member
Joined
·
1,153 Posts
Discussion Starter · #13 ·
I started out with the single oil filter, then went to the dual oil filter set-up. I went from 60lbs cold/50-55 hot on the single set-up down to 50cold/ 40-45hot. I felt that was too much oil pressure to give up, so i went back to single oil filter. I heard all about too much oil pressure washing out the bearings, but I feel good with 50lbs of oil pressure at running temp. I put a 160 degree thermostat in and she runs between 180-190....AWESOME!

 

·
Premium Member
Joined
·
1,153 Posts
Discussion Starter · #15 ·
Here's a video of her Idling, with a few stabs of the throttle. Don't worry Gang, you'll soon get a video of her torchering the skins! This thing really rattles your insides with open headers! In this video it has 3" exhaust with Flowmaster Delta 40 Series mufflers with turndowns. Imagine my neighbors thoughts when I fired her up at 3:00AM Open headers! I'm sure they were laying in bed "Muther fudgering" me. HEY! It was the earliest time that it was ready to drive. How can you have it ready to go, and just go to bed and say well I guess I'll take her for a ride tommorrow? No friggin' way! Needless to say, I went for a ride at 3:00AM!! Sorry neighbors! My closest neighbors were forwarned though.

http://loco4fomoco.com/video/Rumble..wmv


_________________
<font color="blue">L8R,
Rick in Indy</font>
408 Clevor
Remember...Success is a Journey, Not a Destination





<font size=-1>[ This Message was edited by: FATNFAST on 9/7/06 4:35am ]</font>
 
1 - 18 of 18 Posts
Top