Ford Muscle Cars Tech Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys,

I have a '63 Ford Galaxie 500XL with a 390 and a generator, and I've had all kinds of problems with it.

Replaced the brushes a couple years back when the Gen light would come on at low revs and it worked fine for a while, but after a period of storage, the gen light won't go out at all. Replaced and polarized the regulator, but that didn't help. If I push the cutout relay closed, the light goes out, so I'm figuring it has something to do with the gen.

First off, any suggestions for troubleshooting the gen? A search turned up a couple posts about a stuck brush or brushes. IIRC, those unscrew from the casing, right? Can I get to those without dropping the massive gen? I do remember that was a real pain last time I did it, and I don't have ramps any more.
Should I just replace them again, or can I pull them and spray some WD40 on them or something?

Next idea is replacing the gen altogether. Anybody have a source for rebuilds? The normal parts places I buy from - Dearborn Classics, Mac's, just seem to have pulleys and brackets and so forth, and if there were any decent junk yards around here any more, they don't have anything this old.

Or, I could go with an alternator. I'm not real good with auto electricals, and the 3G writeups I've seen look more complex than I want to try. I did a one-wire on another old vehicle I had once, and it charged the battery, but is there a way to make the Gen light work as well? I'm lookng for as easy a solution as I can find.
I'm on my own with this, I don't have any knowledgeable car buddies nearby, so it's up to what I can make work.

Thanks in advance for any tips, pointers, sources, etc.

I do own a Ford truck as well, a '79 F-250 4x4.

Thanks in advance,

Sean
 

·
Registered
Joined
·
2,797 Posts
Have you tried an regular auto parts store like NAPA, Auto Zone? Pull the gen off and take it to a truck/ auto electrial shop that rebuilds starters/ generators/ alternators. If you live out of town maybe a tractor place? It's not rocket science to remove it. 3 wires and 3 bolts. Mark the wire before you remove them.
 

·
Registered
Joined
·
29 Posts
The 3g is very simple to do but you have to get a bit lucky with finding an alt/pulley combo that will work without too many modifications.

You should be able to get a new Generator from Autozone or similar and is a very easy swap as long as you mark everything like 406 said.
 

·
Registered
Joined
·
529 Posts
Are you actually sure the Gen is bad? Measure volts at battery
while running or are you relying on the dash light?

Some times the ignition key does not always spring all the way
back the the "ON" position after you let it go and kind of sits in
limbo between START and ON which can cause the GEN light to
stay on.

Just saying........
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top