Ford Muscle Cars Tech Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, I've been trying to figure out the problem with my brake lights and have come to the conclusion that I don't really know what I'm doing. The running lights do work, so the bulbs seem to be in working order. I changed out the brake light switch with no difference in result. I've cleaned the connectors going from the harness to the fusebox on the firewall with no results still. I've also cleaned the connectors from the turn signal switch since I've read that they go through the same circuit(?).The turn signals don't work and haven't worked ever since I bought the car. This is my first car so I'm just learning how to do things as I go. Any help or tips would be much appreciated.

Key info: running tail lights work, turn signals do not, new master cylinder & new brake light switch.
 

·
Registered
Joined
·
216 Posts
Starting with the brake lites, ck the fuse. If it's good, check for power on one of the green wires at the brake lite switch. No power, ck for a broken wire or bad connection working back to the fuse. Power, take a jumper wire and connect the two green wires at the switch and see if the brake lites work. If they work, switch is bad. If not reconnect the two green wires then go under the dash and locate the wires to the turn signal switch. Find the solid green wire going to the switch. While pushing on the brake pedal, ck for power at that green wire. If you have power, locate the green/orange tracer and orange/blue tracer wires coming from the t/s switch. Again push on the brake pedal and ck for power at those two wires. No power, turn signal switch is bad. Power, take a jumper wire and supply 12v to both of those wires and see if the rear lights work. If they don't work there's a broken wire, bad connection, ground somewhere from there back to the lites.
Turn signals are almost the same ckout. Locate the flasher, turn the key on and ck for power on both flasher terminals. If they both don't show power the flasher is bad. No power, ck the fuse. If they do, go to the same wires you cked for the brake lites at the t/s switch. With the t/s lever in the left signal position ck the green/orange tracer wire and the green/white tracer wire for power. In the right position ck the orange/blue tracer and the white/blue tracer wire for power. The green/white tracer and white/blue tracer wires go to the front lites. The two wires in the left side/right side combinations should have power when you move the switch to the left or right. If any of those wires don't show power the t/s switch is bad. Other things you can try is the 4 wire colors I mentioned. Take a 12v jumper wire and apply power to each then ck to see if the corresponding lite works. If it doesn't you could have a poor connection somewhere. The two connectors at the firewall is a good place to look. Hope this helps and isn't too confusing.
 
1 - 2 of 2 Posts
Top