Ford Muscle Cars Tech Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So, basically I bought myself a 1965 Ford Falcon Futura 4 Door for $1000, all original, but boy does she need some lovin' and I have no clue what to do. So here's the more noteable problems, my blinkers,gauges, and windshield wipers refuse to work now, when I first picked her up she ran great and everything was fine minus the front right drum cylinder was leaking but that was an easy replacement, after a week or so i would have to wiggle the ignition a little for everything to start working again, and then a week or so after that, bam, nothing worked. So I bought myself a new keyed ignition thinking that would solve the problem, and now I am having some serious trouble getting the entire switch system to stay in place and work correctly, would any of you gentlemen have any words of advice or guides to help me on this problem?

Second major problem, actually I should have put this at first because it is MAJOR. I am pretty sure my generator is shot because whenever I would park my car for more than say 30 minutes I would need to get a jump to start, I thought something was wrong with my battery or the wire's where on backwards, so I disconnected the battery, looked it over, and tried to reinstall it, upon connecting my positive the battery will start arching wildly, at first i thought it was normal so i just ratcheted it back into place, and as soon as i did that i noticed a nice trickle of smoke coming from where the generator is, upon noticeing that I immidiately remove my the positive and tried to find a short in the wiring that I could get to but that was to no avail. I bought a refurbished generator from autozone, but unluckily I cannot find any guides on how to replace it, do any of you have any suggestions or guides?


Thanks in advance for any help I recieve, as you can probably tell I am far from familiar in this area of expertise.
 

·
Registered
Joined
·
289 Posts
Congrats on the Falcon and welcome aboard. As for your problems. If it was working fine before and all of the sudden it's having a hard time turning over: I would look at starter solenoid, voltage regulator, and the generator.



The instrument panel and gauges are likely from the voltage regulator going bad and screwed up with your fuses. Check your fuses.
 

·
Premium Member
Joined
·
2,867 Posts
You may want to go on ebay or Amazon and get a repair manual for your car.
Somebody had wired my altenator in backwards. They don't charge well that way.

Also, go over to the TFFN site. Some good info over there and also you can find wiring schematics there to print off.

Sounds like you may be having issues with your headlight switch also.

Jet
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5 (Edited)
I thought only late '65s had alternators, but from the image you are showing me it does rather look like an alternator. 2bird and jetfixr thank you very much for the quick responses and help, I appreciate it very much. I have replaced all of my fuses to no avail. I am going to get dug into checking everything out and posting some pictures after I get home today if it isn't snowing, thanks again for the help so far !

Also, thank you for the warm welcome haha.
 
1 - 6 of 6 Posts
Top