Ford Muscle Cars Tech Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Help! My truck sat for 10 years. rebuilt it with my son for him to drive and it has become a nuisance. First fuel pump lasted 12 minutes. was old. no problem. 2nd pump went 2 months. figured it was just Chinese junk. has eaten 5 more since. total of 7 in 3 months. flushed the tank with kerosene and bolts. ate a pump days later. rubber lines are new. installed a 10 micron fuel filter and the pump went out idling at a stop 2 days later. New pump installed that night. no start the next morning. I will stop now. I am having the tank hot tanked at a radiator shop this week. replacing the steel fuel line, filter, and fuel cap. the fuel cap may not be venting. can't imagine that caused the pumps to fail though. what the hell fails these pumps? side note, the tach is moving backwards as I crank the engine. what causes that? maybe I am chasing a different problem?
 

·
Premium Member
Joined
·
594 Posts
One word: CHINA. They copy old parts with no knowledge of materials. Diaphragms dissolve in E10 gas. You have two options.

1. Go to Summit or Jegs and buy a quality, US made pump. It won't look the same as OEM.
2. Buy an electric fuel pump and mount it on the chassis just below the tank. Find one that makes 5 psi or less so you don't need a regulator and a return line. Wire it up through an inertia switch and relay so it turns the pump off in an accident. While you're at it order a block off plate for the cam driven pump that you will drop in the trash.
 
1 - 2 of 2 Posts
Top