Ford Muscle Cars Tech Forum banner

21 - 26 of 26 Posts

·
Premium Member
Joined
·
4,342 Posts
Where is the modulator adjusted ? If it hasn't been adjusted they usually go in around 3-4 turns to get the correct spring tension. That may tidy it up.. Also a tweak of the band adjustment depending on what you set it at
 

·
Registered
Joined
·
15 Posts
Discussion Starter #22
I have not adjusted the modulator. I installed it straight out of the kit. It's the one with the green stripe.

The new bands were adjusted 10 lbs of Torque then 1.5 out in the front and 3 turns out in the back.

It seems to be running very cool. I get around 140 degrees warmed up using a hand held thermometer at the pan and on the line. This is after a few trips up and down the road.

I will try the modulator adjustment first. Thanks Greg
 

·
Premium Member
Joined
·
4,342 Posts
Yes definitely try the modulator , They always require adjustment.. The green stripe is a good choice

You could try running the front band a tad tight , say back out just over 1 turn , see if it makes a difference.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #24
Yesterday I removed the Modulator and replaced the pin with the longer pin that came in the shift kit. Second gear now comes in later and right where I like it. The 2-3 flare seems to be gone. I drove around for about 20 miles and it all seems good now. I'm gonna put some more miles on it this week and see how it goes. After the long drive my trans temp was 165 so its staying cool.

I have a TCI 2000 stall converter and I can feel it engage right before the 1-2 shift. is this normal? It almost feels like a slight shift. I have always had stock converters so I'm not sure what I'm feeling. Thanks
 

·
Premium Member
Joined
·
4,342 Posts
Good to hear .. The converter hard to say . Ones i've seen here around 2000 stall are barely noticeable . It's possible if you are making some torque it may stall a bit more than the advertised 2000, that might be what you're feeling when it couples up fully , below that is a little slippy to get you up to stall speed if that makes sense .
It can't be too bad or temps would be higher , where you're at is good .

The modulator pin is a good move , if you haven't already i'd still adjust the modulator in slightly. Transo give a weight to set the modulators on a scale and as I mentioned they can usually go in a couple turns to get to their spec
 

·
Registered
Joined
·
15 Posts
Discussion Starter #26
So when I take off in drive, That small rev I was feeling has now turned into a Shudder. When I take off easy in drive it will Shudder after about 20 feet Well before the 1-2 shift. It seems to be getting worse. When I take off in Low and shift through the gears there is no Shudder and all gears shift perfect. I think its happening at 2000 rpms but not sure yet. I will check it later. Any thoughts on what this could be? Thanks
 
21 - 26 of 26 Posts
Top