Ford Muscle Cars Tech Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter · #1 ·
1. My engine runs hot, but do not know what the temp is. I just got a temp * guage and was wondering what is normal operating temp should be.
2. I installed a coolant overflow resivore. I added fluid to the marks where it says "full when cool". I drove it arond for a few days. I checked it when it was hot, and all of the fluid was out of the tank. It should be higher than it was cold. So I added some more, drove around, and it was gone again. I do not understand where all of the fluid is going. When we first built the motor (351c), we thought we had 2 bad head gaskets. We just got a new exhaust system and there was a substantial amount of water comming out of the pipes...both of them. I do not have an x or h pipe, so somehow we figured there were 2 bad head gaskets. We changed them and put it back together. Water still comes from the pipes at start-up. I think that it is condensation, but in the nevada desert, there is not much moisture. Could I have 2 more bad head gaskets or 2 bad heads??? This could also be why it runs so hot. Please post any thoughts you may have.
3. How do you guys with hood scoops keep the water out of your air cleaner/engine when it rains? I want to make my scoop functional, but do not know how to keep the water out.
THANKS A LOT for any help.
 

·
Registered
Joined
·
330 Posts
Discussion Starter · #3 ·
yes, they were fluxed and they said there were no cracks.
yes, they were surfaced.
and yes, I used fel-pro gaskets.
 

·
Premium Member
Joined
·
684 Posts
Is it possible you are running way rich and what your're seeing is excess fuel spitting out the pipes. It's wacky, but weird **** happens. Also the extra fuel will make a gasser run hot. Timing will also affect your operating temps at speed. Good luck. I hope it's not serious. Check the easy stuff first then go from there.
 
1 - 4 of 4 Posts
Top