Ford Muscle Cars Tech Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1 (Edited)
The autolite 4100 that I just rebuilt is overflowing. I am doing some tests tonight to see why the needle isn't seating, but I have a question.

I was looking at the thread and page on the Mrs American 3.14... carb rebuild and noticed a distinct difference in the floats.

A. His are brass, mine are not.
B. His has a little spring on them, mine did not. Did non-brass floats have this spring too? It wasn't there on either float when I disassembled, but is it supposed to be? I wonder if this is why the needed doesn't get enough pressure to close. But, the question would then be, how did it work before?

An illustration is below, look at #13 for the spring I am talking about.
 

·
Registered
Joined
·
7,376 Posts
The autolite 4100 that I just rebuilt is overflowing. I am doing some tests tonight to see why the needle isn't seating, but I have a question.

I was looking at the thread and page on the Mrs American 3.14... carb rebuild and noticed a distinct difference in the floats.

A. His are brass, mine are not.
B. His has a little spring on them, mine did not. Did non-brass floats have this spring too? It wasn't there on either float when I disassembled, but is it supposed to be? I wonder if this is why the needed doesn't get enough pressure to close. But, the question would then be, how did it work before?

An illustration is below, look at #13 for the spring I am talking about.
Hey Mr. J,
Sorry about BraveNet not permitting remote linking. If you will right click on the image you want to reference on the "galaxca.htm" page, you can save the image on YOUR computer, then upload it to PhotoBucket, and then you can post it here.

I don't know what to tell you about the Brass Floats and little Springs.

JC
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
I found the problem with a little research and some help (finally got someone over, much easier when I'm not in the car trying to look through the windshield).

The retaining clips were a little too "stretched" and was allowing the float to rise up. Went to the old ones and everything is good.

FYI: I have found several pics of non-brass floats without those little "springs", so i assume it is correct for them to be missing.

TJG
 
1 - 3 of 3 Posts
Top