Ford Muscle Cars Tech Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Ok, freshly rebuilt c4 trans, installed Hughes manual VB (forward pattern)

1-2 shift is quick and happens as it should. shift to 3rd, and the trans seems to slow the car down, like it is fighting itself. Checked fluid level and it was good, checked gear selector position at trans, everything seems to line up nearly perfect. Modulator and valve are installed, but not hooked up to vacuum.

Should I remove the modulator valve? Could it holding the intermediate band tight in 3rd gear? I checked for a sticky servo...downshifting from 2nd to 1rst seems normal, so the band should be disengaging going down, but I swear something is pulling the trans down in 3rd, and I can only think the band is the culprit.

Any other ideas?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I dont recall, but I adjusted it according the manual. Clutch packs were within tolerance as well.

<font size=-1>[ This Message was edited by: rjstamp3 on 10/29/06 10:30pm ]</font>
 

·
Registered
Joined
·
4,003 Posts
What do the instructions that came with the manual valve body say about the modulator valve?
Is it supposed to be removed?
You adjusted the bands to specs in the manual was that the factory specs? Did the valve body come with band adjustment specs? If so you should readjust to those specs.
When you say the clutch packs were within tolerance are you talking about Factory specs? I assume this is a race car - is there more than .050 free play in the clutches?
What is the overall endplay in the transmission?
If it didn't come with specs then give the makers of the VB a call to find out if it is compatible with what you have built.

Sometimes there is grease put on check balls when the valve body is put together to keep them in place and it causes problems until you get the tranny warm and operate it for the first couple of times. In Third gear there is pressure going to the release side of the intermediate band which pulls it off the drum pretty fast. Does reverse work ok? If reverse and second work well then the low / reverse band is fine. If ytou can downshift from second to low and it works ok then the band is releasing and is probably not pulling the engine down in third. If after getting the tranny warm and working it a couple of times doesn't fix it then give customer support a call and see what they say.
Paul
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
I didnt get any instructions with the VB, so I just installed it in place of the other one. I had to put a bolt and nut through the VB because there seemed to be one extra hole.

Called Hughes, and am being told that I have the wrong valve body for my trans case. I have a screw in modulator, is that indicative of year? Tranny is case fill, the input shaft is 26 spline, I thought I was sure that it was a 70 and later case, but maybe not? will a straight up reverse manual work? Hughes tech dept also said their forward pattern "full manual" needed the modulator installed and hooked up to vacuum...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top