Ford Muscle Cars Tech Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
i have a c4 trans with a stock valve body that has been machined to be a manuel valve body, whenever there is a load on second gear the trans slipps but in 1st and 3rd the trans is solid. i measured the pressure in each gear and all gears got about 145psi but second droped to like 130. would this be a valve body issue? also are stock valve bodys that have been machined junk? thank you to anyone that helps me
 

·
Registered
Joined
·
1,745 Posts
I would start by pulling the servo out and checking the seals. They are probably hard and leaking fluid around the piston causing slippage and pressure loss.
 

·
Premium Member
Joined
·
4,402 Posts
I agree ,there is a pressure drop there in that gear so be checking there first.. BUT 145 is low anyway , is the modulator connected ? Is it a constant pressure valvebody? Most manual VB are up around 200 psi

Alos near all VB's are modified originals
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
the trans has a fresh re-build so the servo seal should be in good shape. i also thought with running a manuel valve body you dident need the modulator so i capped off the hole.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
and the valve body has no gaskit it only has the metal plate between the two bodys so could that be my problem?
 

·
Premium Member
Joined
·
4,402 Posts
the trans has a fresh re-build so the servo seal should be in good shape. i also thought with running a manuel valve body you dident need the modulator so i capped off the hole.
Not always , that's why i asked . You didn't say what make the valvebody was . Transgo do a manual conversion kit that still uses the modulator to control line pressure .
You're right a fresh rebuild servo seals should be fine , BUT there is an issue there causing the low pressure . In 2nd gear there is an issue ..

Now a fresh rebuild with a manual valvebody and only 145 psi , there's something wrong, possibly a V.B issue .
 

·
Premium Member
Joined
·
4,402 Posts
and the valve body has no gaskit it only has the metal plate between the two bodys so could that be my problem?
Not necessarily . Some i've used have no gasket and work fine. The Broader performance reverse manual kits use no gasket and work well.

So what make is the valvebody???
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
i have no idea what make the valve body is all i know is that was a stock one machined to be a manuel. If i went with a TCI would it fix my problem???
 

·
Registered
Joined
·
1,745 Posts
You may have a valve body problem but don't make it worse by buying a TCI.

TCI has a history of poor quality. There are way better options out there like Broaderperformance.com or almost any other brand.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
this car is going to be used for a daily driver/race car, drivablity dosent really matter to me i just want to get the hardest shifting trans possible
 
1 - 14 of 14 Posts
Top