Ford Muscle Cars Tech Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
ok guys, ive got some tech questions and i hope this is the right place to post. but anyway, i have a ford 302 crate engine model is m-6007-x302 and a c4 trans, im thinking it came out of a 70 fairlane. ok so here is the issue after 1k rpm i get a horrible high frequency shake throughout the entire car, up the column, everwhere, so bad i feel it may damage the crank bearings. this happens in neutral and while driving.. shake starts after 1k and up to about 4k after that the frequency become so great it just becomes a buzz and seems to go away. the balancer on the engine is a ford racing m-6316-a50 for the 5.0 crates. im not sure who makes the torque converter or flywheel it came from the customer with the car. i think the flywheel came off an old 289 that was in the car. i think this vibration is coming from one or all three of these parts. any help guys? oh and on a side note, do i need to run a kickdown rod with this trans? it has a vacuum modulator already.
 

·
Premium Member
Joined
·
1,330 Posts
I believe that engine is balanced 50oz. Make sure you have the correct balance flywheel and balancer.
 

·
Registered
Joined
·
10,342 Posts
+1. You have a mix of a pre-'82 28 oz/in balance flex plate, and a '82+ 50 oz/in balancer (damper). Bad. Don't run it until you correct the issue or damage may occur. Verify the correct balance for that engine and use matching balance parts.

David
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top