Ford Muscle Cars Tech Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
OK, bought a used Clarion CD head unit for the galaxie. Mounted it all nice up under the dash, hooked up all the wires, got a set of Sony Xplode 6x9's for the rear deck, but the damn thing won't work! When I put in a CD, it just says ERR 3. Which I'm guessing means ERROR. Tried a couple different CD, checked to make sure it's all wired right, but still nothing. Does'nt even sound like the disc is spinning.
Anyone know whats wrong? I don't have the manual so I don't know what ERR 3 means. I know theres some audio experts on here, RodnAz and a couple others. Ideas?
Any help would be appreciated.
 

·
Registered
Joined
·
64 Posts
LOOK ON FACE OF PLAYER FOR SMALL HIDDEN BUTTON ABOUT THE SIZE OF A PEN HEAD. PRESS IT IN SHOULD BE A RESET.HAD SAME PROBLEM BUT IT WAS ON A KENWOOD SYSTEM. JUST A IDEAL HOPE IT HELPS.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #4
Thanks BING1. I didn't see any little button on the face, either side. Dragman, the radio works, I can scan and seek but get no sound. I didn't hook up the antenna so I guess thats why. Should I at least be getting static or something?
 

·
Premium Member
Joined
·
111 Posts
Best way to figure this out is to go to Clarion's web site www.clarion.com If you look under their support section, they have wiring diagrams and the actual user manual for all of their head units. Most of the user manuals have a section towards the end that lists the error codes and what causes them. If you can't find your unit, try e-mailing Clarion for assistance.
 

·
Registered
Joined
·
63 Posts
Make sure it's grounded very good. Decks will do all kinds of weird things if they're not grounded properly.
 

·
Registered
Joined
·
1,394 Posts
best thing to do is just go back to the radio place. you should go to one of those places that will install these things for free.

besides, it may be a defective. worse case scenario, you'll pay them 20 bucks for them to look at it and fix the problem. you already did the hard part and mounted the sucker.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #10
Well, I gave the thing back to the guy I bought it from. Sucks, now I got a nice set of speakers with no stereo.
Anyone wanna sell a used CD player?
 

·
Registered
Joined
·
672 Posts
I know it's a little too late to help, but you should be getting a static sound coming from your speakers if the antenna is not wired. Did the cd player say error on all the discs you put in? Or just a few? Sometimes newer disc won't play on older head units.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #13
Thanks Rod. When I hooked it up with no antenna, I got nothing from the speakers. I knew I shoulda got something, static at least. As far as CD's go, I tried a couple old Sabbath and some newer disks. Oh well, thanks for the help everyone.

Puttin the call out again- anyone lookin to get rid of an old CD head unit?
 
1 - 13 of 13 Posts
Top