Ford Muscle Cars Tech Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
I have a '98 explorer with a 5.0 engine (112K miles) and the check engine light keeps coming on. I check the codes and it says 1/2 and 2/2 catalyst on left bank. I talked to someone in the auto parts store and they said it was the catalytic converters were going bad. I replaced them and the code still keeps coming up. Can it be the oxygen sensors are bad? Also, I hope I replaced the correct side of catalytic converters. What side is the left bank? Thanks for any help you can give.
 

·
Registered
Joined
·
2,251 Posts
Drivers side= (L)
left or right while your seated in the car...truck
Part store are parts stores
If you get a code for TPS that does not mean it's the TPS it could be a bad ground or connection, you just don't replace the part the code is pointing to.
You have to test it.... Most good scanners will have a trouble shooter that will giude you though the tests but these are $$$$$$ Mine cost 2500.00 and it's a cheap one.....

get it hook up and tested before you spend more money on parts that are still good.
 

·
Registered
Joined
·
1,468 Posts
the O2 sensor being bad will show up on a scanner as an O2 sensor being bad.

The catalyst issue could have been a couple of things, IIRC...

Clevor is right about the machine too $2,500 is NOT one of the colstly ones...

FE
 

·
Registered
Joined
·
247 Posts
go to a Ford dealer and see if there is an updated pcm reprogramming available to change your calibration a bit.
It probably has nothing to do with the o2 sensors.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #5 ·
Thanks for the advise. I used one of those scantools that you purchase at the local autoparts stores. I will take it to shop to get it tested.
 
1 - 5 of 5 Posts
Top