Ford Muscle Cars Tech Forum banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
14,758 Posts
Discussion Starter #1
Well, FXJR (my 16 year old son) has been busy putting the 351 heads and new cam on the comet this winter (for his auto tech class). He finally got everything buttoned up, did the first fire up and according to him, it's knocking real bad, like rod knock!!
I haven't heard it yet and will check it out tomorrow. Obviously, the whole top half of the engine was pulled to replace the heads and install the cam and new timing chain. Is it possible the oil pump shaft was dropped when the distributor was removed? Any other possiblities are welcome...
 

·
Premium Member
Joined
·
684 Posts
This is an outside shot, but is it piston to valve clearance, or lack thereoff? If the motor had marginal factory clearance, and then you had the block and heads milled and has a healthy cam in there, things might be getting TIT, pronounced tight.
If the pump drive has the clippy thing on it it shouldn't of slipped out. You'll have to check it out and report back. Hopefully it's nothing major and it didn't get all fu#$ed up on the initial startup. Later.
 

·
Premium Member
Joined
·
14,758 Posts
Discussion Starter #3
Got an update from fxjr. He says the car ran great until it warmed up, then started knocking somethin' horrible. Oil pressure apparently stayed up the entire time and the car didn't overheat. Piston/valve clearance checked ok. Sounds like we washed out a bearing.
 
1 - 3 of 3 Posts
Top