Ford Muscle Cars Tech Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,050 Posts
Discussion Starter · #1 ·
Okay hoping you guys can help me out. I just did a alternator/march serpentine system swap. Started the car today and have a really strange noise coming from the front of the motor.
Its hard to expalin what it sounds like, almost like a grinding, clanking sound.
To see if it was coming form the accessory drive, i took the belt off, started the car and no noise. Put the belt back on and the noise was back.
If i spin the water pump by hand, its kinda noisey, not like the alternator that is very quite.
I guess my first step is to replace the water pump, what do they usually sound like when they go bad? Its only about 4 years old, but I think it was one of those pep-boy rebuild ones.

Let me know what you guys think, i was also considering getting a shorter belt and trying to run just the alternator/crank to see if I can hear the noise but im not sure if I can even do that.

Thanks
Rich

<font size=-1>[ This Message was edited by: strtcar on 7/24/06 9:04am ]</font>
 

·
Registered
Joined
·
1,311 Posts
I would get a new water pump. Sounds like it to me.
Rebuilds always vary in quality across all the major chains. I always get a NEW water pump,even if a aftermarket one.
It were new when your car was new and they usually last at least 100,000 miles. so why use a rebuilt that tend to last 20,000 to 30,000??
 

·
Registered
Joined
·
847 Posts
Try shooting A little water on the belt when it going this usally will shut a belt up for a few mins. If its the water pump it will still be noisey.

Good Luck
 
1 - 3 of 3 Posts
Top