Ford Muscle Cars Tech Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter · #1 ·
Ok guys we just went on our first real test drive on the new built original 352 and c.o.m total rebuild.. Well got in the ol girl about noon, started right up,let her warm up and off we went.. Trans shifted just fine (do to the vacuum pump we installed) went down the road very well, no shakes, sounded super nice.. Went down the hiway at 60mph and was only pushing 2k or so on the tack.. Had to do some tunning on the fly to the holly 750 but it cleared right up.. It wanted to die in gear..But other then That is was HEAVEN.. Funny story me and the wife went to Hardee's to get a burger and she caught me day dreaming looking at the car and she said laughing, I wished u looked me like that,, needless to say I had to take her shopping!!
 

·
Premium Member
Joined
·
5,912 Posts
My first test drive with the 390 was going so well me and Gal got out on the freeway.:D At 70 mph in passing gear you don't notice when the freeze plug comes out,:eek: only when the detonation brings the car to its knees a minute later.:mad:

Glad yours went better than that!
 

·
Registered
Joined
·
181 Posts
Discussion Starter · #4 ·
I know that's right FE, and I would like to thank you and everybody else that has responded back with GOOD,HELPFULLY,info on all my silly questions over the last year or two.. So thanks again! Iam Fixn to ride the wheels off this thing!!!
 

·
Registered
Joined
·
181 Posts
Discussion Starter · #5 ·
Damn PUTTSTER hate to hear that.. I was a little worried about the 3.0 in the 9" but it ran 70mph and was hitting close to 3k so we should be good for long trips.And thanks for all your help also!
 
1 - 5 of 5 Posts
Top