Ford Muscle Cars Tech Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all,
I need some help please, I have an N reg ford galaxy. I am having problems with it starting
Well actually for example i started my car the other momrning and pulled off the drive only to realise that i had forgotten something. when i got back in the car 1 min later the car wouldnt start. this seems to be the pattern, it will start but when i stop it it will not restart again for various lenghts of time 10 min, 20 min all day etc

anyone have any advice?

thanks a lot
Sylvia
 

·
Registered
Joined
·
3,572 Posts
Hi Sylvia,

I hope someone from England see this, The usual car we're used to seeing is the Ford "Galaxie" which is a very large North American car.

Regardless, I am wondering if your European Ford suffers from a similar malady to its ignition system that some North American Fords seem to. Find out if the car has an ignition module called a TFI ( Thin Film Ignition) these are a known problem and often casue the symptom you describe.


Good Luck and Hope this helps. Stu ( Ex-pat Geordie)
 

·
Registered
Joined
·
4,003 Posts
Are there any symptoms to this no-start condition?
Does it go "Click" but nothing happens?
Does it click, growl but the engine doesn't turn over?
Does it turn over but just not start?
does it make no sound and nothing happens?
Can you put it in neutral and start it? have you tried?
Does moving the shift lever back and forth while trying to start it make any difference?

The more information that you provide increases the chance that we will recognize the symptoms and give you the information that you need to fix it.

Paul
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
update.. I have taken it to a garage and even he is confused...he has tried to put his electrical tester on it.. and he has advised that it could be the ECU..would this make sense as to why it starts and stops with no notice. there are no symptoms as such no clicking it turns over as if it is going to start but just keeps turning over.. I will say that the other day I had to be towed back and when i tried to start the engine it sounded as if it needed a new battery but when we tried it an hour later (after we had been towed) it started again as good as new

Sylvia
 

·
Registered
Joined
·
4,520 Posts
Galaxy is not the same as Galaxie. The last Galaxie was produced in 1974.

read and be amazed!

http://en.wikipedia.org/wiki/Ford_Galaxie
http://www.torinoparts.com/galaxie.html

None had ECU.

Can't help.

_________________
Of all the rest..."There are three faithful friends, an old wife, an old dog, and ready money..."-- Benjamin Franklin, 1738 --

<font size=-1>[ This Message was edited by: Beoweolf on 9/15/06 11:47pm ]</font>
 

·
Registered
Joined
·
1,468 Posts
Beo.... She is a Brit.... Over in England the possibilities of a galaxie having a PCM are numerous....
 

·
Registered
Joined
·
3,572 Posts
On 2006-09-15 12:25, FALCONAROUND wrote:
Beo.... She is a Brit.... Over in England the possibilities of a galaxie having a PCM are numerous....
She has a Galaxy, totally different beast. It is actually a joint venture with Volkswagen. After further study it's MAINLY a VW chassis and gear. So I AM NO HELP!!!!
Stu
 

·
Registered
Joined
·
203 Posts
Hey Guys, this is a Ford Galaxy
http://mud.mm-a4.yimg.com/image/1004907005

Called a 'people carrier' over here, & your right its a joint venture with VW & a spanish company called SEAT ( owned by VW) as for its starting problems, can't help there I'm afraid! too much electronic mumbo jumbo for me! & I'm an electrcian by trade!

_________________
<!-- BBCode Start --><IMG SRC="http://i2.photobucket.com/albums/y33/pop_dragin/mustangblack.jpg[/img]
Street Driven Bracket Racer

<font size=-1>[ This Message was edited by: dragracerdave on 9/16/06 5:56am ]</font>

<font size=-1>[ This Message was edited by: dragracerdave on 9/16/06 5:56am ]</font>

<font size=-1>[ This Message was edited by: dragracerdave on 9/16/06 5:57am ]</font>
 

·
Registered
Joined
·
3,572 Posts
On 2006-09-15 14:55, dragracerdave wrote:
Hey Guys, this is a Ford Galaxy
http://mud.mm-a4.yimg.com/image/1004907005

Called a 'people carrier' over here, & your right its a joint venture with VW & a spanish company called SEAT ( owned by VW) as for its starting problems, can't help there I'm afraid! too much electronic mumbo jumbo for me! & I'm an electrcian by trade!

_________________

Hey Dave where in Northern England are you? Stu
 

·
Registered
Joined
·
1,468 Posts
Where are you living over there in the UK? North? South? I have contacts in the North (Harrogate/Darley), and a friend in the South (London)


FE
 

·
Registered
Joined
·
1,468 Posts
There's a Garage twards Harogate in Hampsthwaite called "Stumps Garage". I have personally turned Wrenches there and would recomment this garage for her Galaxy.

FE
 

·
Registered
Joined
·
3,572 Posts
On 2006-09-16 03:24, dragracerdave wrote:
I live just south of Leeds,not too far from Harrogate,
Ya call that NORTH! I'm from Newcastle originally!
Your MII must be a rare site in those parts. ( actually they are rare site in these parts come to mention it). Cheers! Stu
 

·
Registered
Joined
·
203 Posts
Hey Stu, its far enough North for the southeners to think nothing lives up here lol!
Your right theres not too many Mustang II's around, though we used to have 3 race at our local dragstrip! I like the fact that I can go to a cruise & not see another one,
How come your over in the Canada now?

_________________

Street Driven Bracket Racer

<font size=-1>[ This Message was edited by: dragracerdave on 9/18/06 3:31am ]</font>
 
1 - 14 of 14 Posts
Top