Ford Muscle Cars Tech Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,436 Posts
Discussion Starter #1
So, I got a rebuilt C6 transmission from a shop in Florida and it sat in a shop for about a year before I was finally able to install it behind my 472. The trans will only shift into 1st. It will not go into reverse, or any other forward gears, not even when manually shifting. My shop took off the tailshaft and checked the governor and the vacuum modulator, and all was well.

What else might it be? I am assuming the next step would be to check the valve body and make sure it was installed right.

Now, with that being said, even though the transmission was kept in the shop, there were a few weeks where they were having serious condensation issues in the area the trans was being stored. I'm a newb when it comes to transmissions so I am unsure of where there are openings in the transmission case that moisture could get into and affect it. Are there any obvious indicators that might signal that water got into the trans?

Any tips would be appreciated...
 

·
Registered
Joined
·
1,786 Posts
I dont think I've heard of a rebuild that wouldnt go into reverse, but I suppose its possible. I've seen some strange things that they will and can do, and some odd "fixes" that work, but without the reverse I will keep some of the tranny shop secrets safe. Maybe someone else has a suggestion. I would say it sounds V/B related tho....
 

·
Banned
Joined
·
6,355 Posts
ist only .V/B shiftshaft isnt hook to external linkage/arm

drop pan and valve body , install correct way

your local trans shop didnt think of that ????? but checks the mod & gov.
 
1 - 3 of 3 Posts
Top