Ford Muscle Cars Tech Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
504 Posts
Discussion Starter #1
Hi

Ive owned my Galaxie more than a year now, and the fuel gauge has worked ok. But at the end of my around 2000 miles long holiday trip, the fuel gauge not reaches F, even if the tank is full. The gauge stops just right of the dot between middle and F. The gauge moves propotionally with the fuel level gets lower that that gauge postion. Ill try ground the sending unit and see if the sending unit works. Or could it be that the float has a hole and that its fuel inside it, when it behaves like that?
 

·
Premium Member
Joined
·
1,330 Posts
A leak is possible.
 

·
Registered
Joined
·
504 Posts
Discussion Starter #3
A leak from the tank? The tank is nok leaking. Maybe you ment another type of leak, like a pinhole on the float?
 

·
Premium Member
Joined
·
5,864 Posts
Mine started doing that, too. Can't get it full past 3/4. I was thinking it was the sender. I have a multimeter and plan on seeing how the ohm readings matched to the specs. One day :rolleyes:. Does yours go way past E or is it normal on that side?

I don't agree with the leak in the float idea - otherwise what would stop it from filling up and sinking to the bottom? :confused:

putts
 

·
Premium Member
Joined
·
5,864 Posts
Site is LOOKING GOOD, Gary!
 

·
Registered
Joined
·
504 Posts
Discussion Starter #8 (Edited)
35 dollars for a new sending isnt expensive, but Ill check first if the gauge works as it should to be sure. I havent tested it the gauge passes E much, cause its few gas stations here and its not nice standing alone on the mountain;)
 
1 - 8 of 8 Posts
Top