Ford Muscle Cars Tech Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
within a few minutes of starting the fuel pressure slowly drops to zero at the gauge and the glass filter at the carb goes empty. the inside of the tank is spotless and the pickup is clear. the system has new hard and soft lines, new marine type filter near the tank, new electric carter fuel pump, new holley regulator and gauge, new inline filter w/ sight glass just before the carb, and new edelbrock 4bl carburator. i can't find any obvious leaks between the tank and the carb and there don't seem to be any leaks in the carb. the pump nozzles aren't leaking and i don't see any gas leaking down the the throats of the carb. it doesn't seem to be a tank vent problem because taking the cap off doesn't help. i've even tried another electric pump. same problem.
has anyone had any problems w/ the holley regulator? this problem is making me crazy. any suggestions?
thanks.
 

·
Registered
Joined
·
196 Posts
Discussion Starter · #2 ·
the folks at holley finally answered the tech line. they said that the liquid filled gauge can become pressurized as it heats up under the hood. when this happens the needle slowly drops. to bad they didn't mention this in the installation info since high underhood temp is to be expected. they said if the gauge is mounted vertically, to use a needle and poke a hole through the plastic plug on the back of the gauge to relive the pressure. sounds like a crude solution. i'm going to try this before i go any further.
 
1 - 3 of 3 Posts
Top