Ford Muscle Cars Tech Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Help needed, 1965-66 C4 valve body problems and no upshifts.

Having two problems:
After this transmission became weak more and more slow shifting, we did a rebuild.
During rebuild the valve body springs and valves got mixed up.
Also don´t know if there was a check ball of rubber disk (95% sure nothing came out), and I cannot find the right exploded view for this valve body year.

First question is: can someone look at the pictures and tell me which spring and/or valve is in a wrong place? Or does someone have the right exploded view? Is there a check ball or disk inside?
Maybe there is nothing wrong, so I need only confirmation that it´s OK.

Second, and most important question:
Before and after rebuild, there still is no automatic 1st => 2nd and 2nd => 3th shift. In fact, till now there is no 3th at all...
The transmission doesn´t upshift!

When we talk about the shift pattern "small o" - "green O" - "L":
- "small o" gives second gear only, will shift manual 1st to 2nd (or reverse) when selector comes from "green O" (or goes reverse), which is understandable because it will start in 2nd only and should shift up to 3th.
- "green O" gives first gear only, which should be 1st, 2nd and 3rd.
- "L" gives first gear only, which is normal.

We did not open the govenor during rebuild. Shop air pressure will give the "good sound" that govenor valves are not sticking.
There is a new vacuum modulator inside the transmission and even lowered it´s spring pressure.
Any clues for this problem, besides opening the govenor?

I hope you technicians will respond!
Thanks, Jeroen
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The C4_05.jpg shows my valve body. Did find that one too, but thanks a lot!
On the other hand I still can´t find any check ball and puck information.
 

·
Premium Member
Joined
·
4,401 Posts
I have the right Trango diagram with descriptions on each spring. It is a PDF file but not sure how to add it on here .
That valvebody has no checkballs , they do use the puck but not being there wont affect things . Everything looks in order in your pics . What preload is on the modulator pin ?
PM me your email and i can send the diagram
 

·
Premium Member
Joined
·
1,025 Posts
JPF12, I'd pass on rebuilding that green dot VB if I were you. Find a 67-69 VB and get a trango kit for it and rebuild it. The later 67-69 VB is better and will give you the shift pattern 1st-2nd-3rd so you can have some fun with it.

The green dot trannies were one of fords earlier C4's that most drivers didn't like because of the shift pattern so ford later changed it to what most of us here know and use. Call some of your local tranny shops and ask them for a later 67-69 VB and they bolt right in and you even get a later filter set up which makes things better too.

Do a search in the C4 transmission forum for green dot VB change and see what you get and read them. I've got a green dot in my 66 which works fine so I'm not touching it till it's time for a rebuild. I have a 67-69 VB, later filter set up, deep pan and shift kit just waiting for that time.

If you plan on keeping your engine under 300 hp then that green dot will handle it but if you want more hp then I'd find a 67-70 C4 and rebuild it and stick her in.
 

·
Registered
Joined
·
861 Posts
Rick this original post was from Feb 2012, Some spammer thought he would use it for advertising.
 

·
Registered
Joined
·
10,309 Posts
Shoot the spammers down! :D Just click on the "!" button under their name and type something like "SPAM" in the box. Click OK and you're done. When the Moderators get to your message, his posts will disappear.

David

 
1 - 12 of 12 Posts
Top