Ford Muscle Cars Tech Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
I need help! I just tried installing a new grant wheel in my 63 fairlane. I ordered the 4286 install kit from Grant. It screwed all the way down but it leaves a gap between the new hub and the cover for the turn signal I've tried contacting Grant but no response. I'm not sure if there is a way to adjust the column to make it fit or not. I removed the stock wheel myself and there wasn't a gap. I'm very frustrated and don't know what else to do. The car hasn't been driven in over 25 years and I'm hoping to drive it this summer for the first time. But that's hard to do with no wheel. Thanks in advance fellas.
 

·
Registered
Joined
·
262 Posts
my 67 is the same. about a 1/4 inch.
Cant really suggest anything short of making a longer beauty collar your self.
 

·
Registered
Joined
·
1,064 Posts
I got the fix for this from Bondi Automotive, a local custom shop, the owner,
Ted is a Ford guy who had so many customers coming in asking for a fix for this problem, he developed a kit. I don't recall all the parts included, but, his fix does include a brushed aluminum collar that takes up that gap & looks factory.
I will send you his contact info if you like, shop is in Ontario, Canada
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #5 ·
It looks like it should go further down. The horn contact doesn't touch. Neither does the turn signal canceling cam. It just bothers me. I don't want to run the stock wheel because I don't like it sittin on my lap. I really want to know the difference between the two kits that are supposed to fit.
 

·
Registered
Joined
·
262 Posts
oh, I see. your adapter isn't going on far enuf. never mind what I said. thought you were talking about the beauty collar to shift collar/blinker collar. sorry
 

·
Registered
Joined
·
67 Posts
If you have a solid shaft you should be able to loosen the column clamp under the dash and the plate at the firewall and slide the mast up to close the gap. 4286 should be the right adapter, but if you have a split shaft with the rag joint that might pose a problem. Here's mine with a 3286 adapter which is the predecessor to the 4286. Supposedly they are identical.



 

·
Registered
Joined
·
97 Posts
I have the same problem with mine. There's a gap that is pretty much an eye sore. The roll pins that come with the kit that are supposed to replace the blinker canceling can do not work with this gap. I had to pick up some longer pins. They work now but the gap is still there. Also the horn doesn't work either as u mentioned. The pics that are posted below look awesome. My advice, copy him.......I know I will

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #9 ·
Awesome! Thank you so much. I'm gonna try that when I get a chance. In the process of getting the rest of my brake lines ordered. Then gotta paint the underbody and rear axle. Really want to see this thing run properly. Gonna be a tribute to my great grandma since it was her car. Thanks again!
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #10 ·
Here's the gap which I'm finding more people with this problem


And I imagine that I am looking at a rag joint too. This correct?
 

·
Registered
Joined
·
67 Posts
Unfortunately, that is a rag joint.:( I was afraid of that. Probably time to look into Rogers lead for the fix.
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #12 ·
She's dirty as hell down there lol. I wonder why they (Grant) haven't fixed this since it seems to be common.
 
1 - 12 of 12 Posts
Top