Ford Muscle Cars Tech Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
Has anyone used an ARP oil pump driveshaft with stock oil pump and stock distributor?

I dropped one in my motor, thinking everything would be fine and dandy. I haven't installed the distributor or attempted to prime the pump yet. But I've heard from a couple people that the ARP shaft may be too long and I'd have to shave a 1/4" off the pump end of the shaft to make it seat properly.

Can anyone here confirm or deny this problem? I just put the motor back in the car a couple days ago, I don't want to have to pull it back out just for a possibility, if I don't have to.

I email Summit tech support (bought the shaft from them) two days ago but they haven't replied yet.

Thanks for any info.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #2
I guess that's what I get for listening to rumors.
I attempted to put the distributor in tonight to see if it would fit. It didn't. So I compared the old shaft to the distributor and the packaging from the ARP shaft (the shrink wrap was still in a perfect mold of the shaft). I called Summit if they knew if I might have the wrong shaft, I didn't. They gave me anumber for ARP so I called them. They had no clue about any possible problems.

So after looking down the distributor hole 50 times, I figured out the retaining clip was too high on the shaft. So I used a small screwdriver to push the clip down some and guess what, The distributor fits perfect now...


Oh well, lesson learned.
Thanks anyway.
 
1 - 2 of 2 Posts
Top