Ford Muscle Cars Tech Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
After getting no response to the 500 XL dash badge, I assume I have the
only one known to mankind-lol

Next question-Battery is fully charged-Both horns won't blow correctly-
kinda half fast each, but either blow fine by themselves with either
horn plug connected. Grounds to both are excellent. Must be an electric
thing?
 

·
Registered
Joined
·
2,301 Posts
The part number off the badge is a 1967 Galaxie part number, that I can tell you, so you know it is year.
 

·
Administrator
Joined
·
21,759 Posts
My horns are the same way. I have to push on the horn ring in just the right place to get them both to blow at the same time. I've cleaned the contacts and everything but really didn't help, it's just something I'll live with. They do work real well when removing the horn ring though. Maybe a new horn brush or whatever that little springy thing is called that makes the horns honk and contacts the horn ring.
 

·
Registered
Joined
·
1,627 Posts
If the horn rings are like my Mustang's horn ring, there is a screw in the steering wheel assembly that is really a height adjustment for the outer contact ring, not a securing screw to keep things tight.


If that screw is tight, that is your problem, it should be about 1/2 travel on that screw..... I can't expalin where to find it, but it is a singluar screw and none others are like it on the contact ring. A phillips screw if I recall.

Look at the inner contact ring vs the outer contact ring, they should both be the same height and level to each other.
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #5 ·
Well fellows, I have a Grant st. wheel and adapter (New). Today I ran a wire from the battery in series and they worked great, so I will trace my wiring back and find the problem. I'm losing voltage somewhere. Thanks yall
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #6 ·
Horns fixed-after finding 12 volts at the harness connection, I went to my ole ford guru and he solved the problem. Put PB Blaster down both horns and the adj. screw hole and everything blows loud and clear!
 
1 - 6 of 6 Posts
Top