Ford Muscle Cars Tech Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
401 Posts
Discussion Starter #1
Hi,

I have just removed most of the trim from my 63 fastback. I am looking at the trunk lid and the word "GALAXIE"
How do you remove the lettering without messing up the lettering?
I have had some bad experiences on other cars, so I thought I should ask the question.

Also, the rear quarter panel hatch marks are held on with ring type clips. There are pins that come through the body and they have ring type clips that are notched to grab the pins as they are pushed in. How do I remove those without breaking something?

Thanks for the help.

Silas
 

·
Premium Member
Joined
·
401 Posts
Discussion Starter #2
Well, I have views but no comments. So I will try my best.
Perhaps there are no tricks.

I am going to put some tape on the paint and then use something to pry up on the letters. I have some molding and trim removal tools, so I will start with them - they are softer.

I will let you know how it goes. I only posted because I have had a bad history of breaking things, maybe more patience and we will see. I would love to not damage the letters.
 

·
Registered
Joined
·
160 Posts
The letters are pretty thick and should be OK--just go easy. If still attached as done from the factory, they have little lead crush connectors on the prongs that go into the trunk (2 prongs per letter, top and bottom). My Dad was able to save the leads on his, but you can buy more if needed. My Galaxie just had them glued on thanks to a previous crappy repaint effort by former owners.
 

·
Registered
Joined
·
2,797 Posts
For the trunk letters, open the trunk and look on the back side. You will see the prongs coming through. Take a flat punch and tap them out evenly. They will come out fairly easy. On the hash marks on the rear quarters, use a regular pair of pliers and grab the clips on the side and pull them off with a twisting action.
 

·
Premium Member
Joined
·
401 Posts
Discussion Starter #6
Thanks for the comments and help. I managed to get a few of the letters off in the short time I had in the garage today. The "X" and the "E". It took patience.

I do not see the prongs on the trunk lid. I will look again, maybe I did not look close enough. It seemed like there was no opening to get at them. I know on the hood that is true. I will check again.

Wow, I am shoehorning the car together just enough to take it to a window shop to have the rear window removed. I will then take it home and clean it up and send it to the paint shop for a cheap "for the time being" protective paint job. I have not the time or funds for a better paint job right now. I need to get the car back on the road.

We all know that every time you take something apart it leads you to take yet more apart. I am trying my best to draw a line in the sand out of necessity. The good news is that it is registered and up and running for the first time in six years. Can't wait to get on the road.

The 390 purrs in the driveway. Oh boy
 

·
Registered
Joined
·
2,797 Posts
Sorry my mistake there is no openings on the trunk lid. I was thinking of the hood.
 
1 - 8 of 8 Posts
Top